Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,725,946

members

60

online now

1,888,068

discussions

Back to Top

My Account Page Problems?

Posted by
Bronze Problem Solver

Message 1 of 4
1,661 Views

 

Overview page:  shows we have video and internet.  Nope, we should just have internet.  I've  been told it's just a "placeholder", even though the page says it's connected, and I should "just ignore it".

 

Users page:  only shows the primary account.  The three secondary accounts are nowhere to be found (although they seem to be functional.  At least Thunderbird checks for and downloads mail)  I've been told the CSRs can see them, so I "should just ignore it."  That might work until I need to change something, I guess.

 

Settings page:  My last name is now "undefined".  Smiley Happy  (Maybe I should keep it, I kind of like that.)  Phone numbers, email addresses, account number, all missing.  No explanation offered

 

This is coincidental with receiving two emails from Comcast thanking me for the recent order I never made nor authorized, and confirming the changes I never asked for nor authorized, but which seem to be the same internet only, I've had for quite a while.    Oh, and my bill may "vary a bit" due to the one time charges and pro-rated charges, again for changes I never asked for.  This, too, I was told to "just ignore."

 

I called, got hung up on a couple of times, bounced around while the East Indian folks named Fred and Joe chased an issue I never asked them to investigate, some mythical report they claimed I made about "someone hacking into my account".  (They also did a creditable job of trying to sell me unwanted and unneeded services  Smiley Happy)  Their advice on the problems is listed above.

 

Anyone else seeing these or other odd stuff?

3 REPLIES
Posted by
Bronze Problem Solver

Message 2 of 4
1,551 Views

And the problems continue unabated.  At least no one's tried to install new stuff (so far).

Posted by
Bronze Problem Solver

Message 3 of 4
948 Views

And another month with no improvement. 

Posted by
Regular Contributor

Message 4 of 4
526 Views

WTP, me too!   I go round and round and try and try, getting results of error messages of one kind or another--such as "Bad Image."

 

I am having problems with lots of Comcast/Xfinity User Interface Applications, Websites, etc.,

 

By the way, you do not even have any "Avatar"  graphic or picture next to your name any more--Not even a "canned Avatar."  Have you noticed THAT, yet?  I know, this is the least of your and all of our problems.  Also, maybe, I am not remembering correctly, any more--aren't you a Forum Volunteer? with title of  "Problem Solver" ??  If so, you no longer have your "banner" at the bottom of your posts.

 

I believe all of the problems/malfunctions have been and are being caused with the massive Comcast/Xfinity re-designs, re-brandings (from Comcast to Xfinity).  All these re-designs are over countless, inter-related, MASSIVE platforms--when each platform, in and of, itself--is highly complex.  These, then, have to be linked to individual Customers, as well as, linked to each individual Customer's services, equipment, bills, etc.   And these ALL have to be synchronized.  Further, I believe that these have to be accomplished by quite a number of third-party contractors.  Maybe, this was all too much for a reasonable amount of time for these things to work for the Customers, in a reasonable amount of time.  I, know, that I am so, very confused--no matter how much time and effort I have spent trying to understand how these work.  As soon as I think I understand how to use one thing (when I can get whatever it is to work consistently), that one thing starts malfunctioning.  I think this might, actually, take some more years, to work properly.  Although, I hope not.