Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,651,614

members

10

online now

1,826,911

discussions

Back to Top

Error on MyAccount Page

Posted by
Visitor
  • Congrats on Posting your first topic!

Message 1 of 5
1,598 Views

After login, I try to navigate to the MyAccount page and get the following error: 

 

"Sorry,  A communication error has occurred.  We have been notified and are looking into the issue.  Please try reloading the page or coming back later."

 

I have cleared cache and cookies multiple times and I have tried on IE 10 and the latest Chrome borwsers.  Any idea how I can fix this?  It was working earlier today.

4 REPLIES
Posted by
Problem Solver

Message 2 of 5
1,588 Views

Hello jeffreygrimshaw,

 

Thank you for posting! It is a known issue and I can assure you we are working diligently to get it resolved. Thank you for your patience in this matter. 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Visitor
Message 3 of 5
1,315 Views

Did your account ever get fixed?  I started my service with Comcast in November and I have never been able to access my account online because of the same error.  It's so frustrating.

Posted by
Visitor
Message 4 of 5
925 Views

I'm having the same issue.  I've read through the web and each time it seems to take a private session to fix.  Poor programing from my view.  It seems a bit suspicious to me that you are pushed to pay through a credit card as opposed to just making the software work right the first time. Very disappointed.

Posted by
Visitor
Message 5 of 5
799 Views

I have same issue     Once in awhile I can get on but then this.    Very frustrating!    Should be fixed I think this is a tech company no