Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,725,369

members

72

online now

1,887,389

discussions

Back to Top

Can't sign into Comcast.net from anything but Chrome.

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 1 of 4
190 Views

I cannot sign into Comcast.net from any web browser other than Chrome. Neither Brave nor IE 11 will work. Is there a fix for this?

3 REPLIES
Posted by
Service Expert

Message 2 of 4
159 Views

dcalderwood wrote:

I cannot sign into Comcast.net from any web browser other than Chrome. Neither Brave nor IE 11 will work. Is there a fix for this?


Tried Firefox?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Gold Problem Solver

Message 3 of 4
131 Views

dcalderwood wrote: I cannot sign into Comcast.net from any web browser other than Chrome. ...

"Cannot sign in" doesn't give us much to go on. What happens when you try? Any error messages? The more details you can provide, the better, although take care not to post any personal information (see http://forums.xfinity.com/t5/Forum-Community/Forums-Policy-and-Guidelines/m-p/2618379#M1).

Posted by
New Poster
  • Congrats on Posting your first topic!

Message 4 of 4
29 Views

Sometimes when I attempt to sign in from any browser except Chrome, I get a blank page or (in Brave, which is basically a fork of Firefox), I get a message saying there are too many redirects. Oddly enough, I was just able to sign in from Brave. Go figure.