Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,841,285

members

1,639

online

36,035

topics

Top

two problems; no video or email icon on webpage (no pics with stories on webage. Cannot connect directly to email (certificate error)

New Poster

two problems; no video or email icon on webpage (no pics with stories on webage. Cannot connect directly to email (certificate error)

Can you help me get my comcast web page back.  I get the webpage but not the pictures (except main pics)  No videos (says loading)    I had this two days ago and just went out and no matter what I try I cannot retrieve the pics on the website.   I can use morzilla and it is ok but Ihave all of my information on internet explorer and I do not want to use another browser. 

 

Another problem is when I get into email (on internet explorer) I get a certificate error and then can access if I click the sentence that says not recommended. 

 

What is going on?  I have used internet explorer with comcast for many years and never a problem.   Can you send me some suggestions on how to fix this problem?  thank you

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 0 replies
  • 545 views
  • 0 kudos
  • 1 in conversation