Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,435

members

1,201

online

29,150

topics

Top

email

New Poster

email

Having an account with Xfinity/Comcast doesn't seem to help; my email hasn't loaded all day, and when it does load, it's SLOW!  There isn't any service 'interruption'/problem indicated.  Does anyone know what's going on? 

Email Expert

Re: email

One thing you can try----------------
Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: email

Thank you! Smiley Happy

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 2 replies
  • 236 views
  • 0 kudos
  • 2 in conversation