Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,759

members

446

online

29,201

topics

Top

email

Frequent Visitor

email

when I click on emails, nothing happens....constant circle, circle...

Email Expert

Re: email


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way. If it works OK then you will know the problem probably lies with the first browser. eg: if you are using Internet Explorer, try Chrome or Firefox.

Also, you could try switching from the Full version of Xfinity Connect to the Lite version. Go to Preferences>>>>General, and see which one you're using now. Full is the default. Select the Lite version.

If you are using IE 10 or 11, make sure Compatibility mode is enabled for comcast.net. You will find it in IE under "Tools".




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: email

Thanks..that worked...looks different....and I have to click on 'display images'.....thats ok tho, as long as it works....why did the full version not work? I had been using it for years...

 

Email Expert

Re: email

"Display Images" is normal.  It's a security precaution to keep you from clicking on an image in an unsolicited email.  Are you saying that you solved the issue by switching to the Lite version of Xfinity Connect?  If so, it is intended for use by people using an older version of their operating system or browser.  Lite requires less "horsepower" in internet terms, because it has fewer demanding bells and whistles.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Frequent Visitor

Re: email

Yes it works now that I switched to the "lite" version....I went back to the other version, just because, and it still did not work....went back to the lite version....works...guess I need an upgrade on my operating system...Thanks again for the help.

 

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 4 replies
  • 421 views
  • 0 kudos
  • 2 in conversation