Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,840,901

members

809

online

35,935

topics

Top

email

New Poster

email

Is anyone else having problems connecting to their e-mail? Each time I click on the e-mail symbol I get directed to the Xfinity paqge.  

Email Expert

Re: email

That is normal, unless you keep getting it and cannot get to the email Inbox page.  If that is happening---------------------

 


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way. If it works OK then you will know the problem probably lies with the first browser. eg: if you are using Internet Explorer, try Chrome or Firefox.

Also, you could try switching from the Full version of Xfinity Connect to the Lite version. Go to Preferences>>>>General, and see which one you're using now. Full is the default. Select the Lite version.



If you are using IE 10 or 11, make sure Compatibility mode is enabled for comcast.net. You will find it in IE under "Tools".




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Contributor

Re: email

Your instructions, just like comcast's are wrong - there is NO "General" option - I have logged in twice in both Firefox and IE11 - you need to stop copying and pasting Comcast's 'wrong' instructions.

Contributor

Re: email

I have also failed when using FireFox (I have posted a similar complaint: look for "Loop" "WebMail" "FireFox") ...

 

I was able to get in when I launched MS IE instead, and said "proceed anyway" when presented with the security dialogue ...

 

Hope this problem gets resolved to our satisfaction, and quickly ...

 

:-(

Gold Problem Solver

Re: email


DoverPARon wrote: ... there is NO "General" option ...

Does https://betapf.connect.comcast.net/ help?

Contributor

Re: email

503 Service Unavailable is what I get when I click on your suggested link? Tried several times now.  I have been able to access email via IE but this is not a resolution of the problem. Firefox is my main browser and has been for 4 years now, what did Comcast/Xfinity change in the last 24 hours that has me in this endless looping within Firefox?  IE is too sketchy to be used on a regular basis.

Email Expert

Re: email


DoverPARon wrote:

Your instructions, just like comcast's are wrong - there is NO "General" option - I have logged in twice in both Firefox and IE11 - you need to stop copying and pasting Comcast's 'wrong' instructions.


I'll try this one more time;  when you click on Preferences from the Inbox page, you should see this-----------------------------------




Screen Shot 2016-02-22 at 11.29.44 AM.jpg



When you click on General, you will see the place to click on "Version".  When you click on that it will look like this---------------------------




Screen Shot 2016-02-22 at 11.46.35 AM.jpg



What happens when you click on Preferences now?  What are you looking at?








Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Contributor

Re: email

OK, first of all, you cannot access the inbox or any email functions using Firefox so for any firefox user reading this, do not waste your time trying. Now, I see that since I was able to access my email using IE before you made this latest post (which I do appreciate) I do now see the "General" preference option you are referring to, but again, for anyone reading this, the instructions given work "if" you can access your inbox and in today's case that is not possible using Firefox, only IE.

 

"Latoque" thanks for doing Comcast's job for them but again I really do appreciate you taking the time to follow up!

Gold Problem Solver

Re: email


DoverPARon wrote: ... you cannot access theinbox or any email functions usingFirefox so for anyfirefox user reading this, do not waste your time trying. ...

Using Firefox here, no problem. Does https://web.mail.comcast.net/zimbra/ bring up webmail once you are logged in?

Silver Problem Solver

Re: email

I'm using FIrefox 44, and it is no longer working for mail. It did work earlier today.

Contributor

Re: email

After following the preference change instructions I shut down both IE and Firefox, cleared cache, logged back in via Firefox and was able to get to my Inbox within Firefox.

 

IRT your question using the link, yes, I am able to get into the email but not sure if I would be able to using your link if I changed back my preferences - again my msg to Comcast - What did you change in the last 24 hours that has affected Firefox users?  Really sad that non-Comcast employees have to resolve technical issues such as this one but I am thankful for all who have taken their valuable non-paid time to do so!

 

Also, it would be nice if Comcast Chat worked! When I initially encountered this problem I attempted to open a chat session and all it did was clock for about 25 minutes before I finally shut the tab.

Silver Problem Solver

Re: email

I deleted all of the comcast and xfinity cookies. That seems to have fixed it.

Contributor

Re: email

I had cleared my cache about 1 am this morning using CCleaner so that should not have been an issue for me this morning? But again I will stay with the "Lite" version and hopefully this will resolve any future issues.

Contributor

Re: email

And now for the latest SNAFU on this ... When I tried to log back in to this Forum (had to use MS IE; would not work with FireFox: kept looping on a "Registration" page ... what!?); I landed on a page that said I needed to Enable cookies ...??? Hello!? My cookies were already set to Accept All ... ???

 

DoverPARon is correct: there has been a server side program change that (was NOT regression tested and) has caused fallout ...

 

PLEASE FIX  :-(

 

Forgot to mention that MS IE says that there are ERRORS with the Comcast SECURITY CERTIFICATE

Silver Problem Solver

Re: email

There has been a longtime quirk with 'cookies not enabled' with xfinity.com and Firefox. I found you sometimes have to wait 10-15 seconds after the page finishes loading before trying to log in.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 14 replies
  • 516 views
  • 2 kudos
  • 6 in conversation