Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,857,190

members

699

online

29,931

topics

Top

e-mail

New Poster

e-mail

When i am in Xfinity e-mail I repeatedly get a message that says "A webpage is slowing down your browser. What would you like to do? Stop it. Wait." I usually say stop it, and the problem seems to go away, but only temporarily. Any thoughts?

Email Expert

Re: e-mail

What else do you have open in a browser window or tab?  What you are describing is not unusual.  Try clearing your browser's cache/browsing history, then close it out and re-start it in a fresh session.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: e-mail

I usually only have one tab open at a time. I'll try "clearing the browser's cache/browsing history" and restarting, if i can find the "cache/browsing history". (Not a tech wizard here.) 

Email Expert

Re: e-mail

That is a function of your browser, and they're all a little different as to how you do it.  This should help you out----------------

 

http://www.computerhope.com/issues/ch000510.htm




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 3 replies
  • 204 views
  • 0 kudos
  • 2 in conversation