Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.








connection not private message

New Poster

connection not private message

I recently began getting what look like a lower case letter "i" in a circle in the search bar before a web address. When I click on the circle, it says "your connection is not private". I have not had this problem before. Recently my internet stopped working and we had to disconnect and re-connect the router. I'm not sure if that is related, but a live chat with Xfinity could not resolve the problem. This concerns me. Can anyone offer any insight? Thanks.


Re: connection not private message

This is just your browser informing you that the page has been delivered over the HTTP protocol rather than HTTPS.   Both Firefox and Chrome show this now, I'm not sure about others.  The browser vendors are making a bigger effort to identify plain HTTP sites in the hope that more site authors will switch over to HTTPS instead.


It's not really something to be concerned about and has nothing to do with comcast.  Your browser probably just auto-updated itself recently and the new version now displays this identifier.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 2 kudos
  • 2 in conversation