Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,860,824

members

1,334

online

29,419

topics

Top

SMTP Comcast.net (offline) on Mac but not iPhone

Regular Visitor

SMTP Comcast.net (offline) on Mac but not iPhone

Suddenly this morning on my Mac using Mac email through Comcast.net my outgoing mail server, Comcast.net is offline.  This means I can receive emails but cannot send them.  I have not made changes of any kind.  On my iPhone, all is well and I can send without any issues?  What could have happened?  And how do I fix?

Gold Problem Solver

Re: SMTP Comcast.net (offline) on Mac but not iPhone

Please post the settings you are using and the complete error message uyou are receiving.



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Regular Visitor

Re: SMTP Comcast.net (offline) on Mac but not iPhone

The message is "Cannot send message using Comcast.net.  The SMTP connection to server SMTP.comcast.net failed." Comcast.net (offline).

 

Settings wise, it says my SMTP server, COMCAST.net is offline.  When I click on Advanced it shows port 110, use SSL and authentication password.  Is there more info you need?

 

Regular Visitor

Re: SMTP Comcast.net (offline) on Mac but not iPhone

After reading through some of the posts on this site, I went in and changed my password.  However, that did not fix the problem.  My "resident" techie (son-in-law) said the port should be set at 586 but it's at 110.  I have changed it twice and it somehow changes back to 110.  

 

HELP!

Gold Problem Solver

Re: SMTP Comcast.net (offline) on Mac but not iPhone


jfeller wrote: ... My "resident" techie (son-in-law) said the port should be set at 586 but it's at 110. ...

For sending, neither one of those is correct. The SMTP port should be 587 or 465 with SSL. See http://customer.comcast.com/help-and-support/internet/email-client-programs-with-xfinity-email/.

Regular Visitor

Re: SMTP Comcast.net (offline) on Mac but not iPhone

I continued to read messages and finally tried again to delete and reenter my password and one of those apparently fixed the problem.  

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 5 replies
  • 4655 views
  • 0 kudos
  • 3 in conversation