Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,842,918

members

562

online

36,287

topics

Top

Problems with email accesss

Regular Visitor

Problems with email accesss

Since I was notified of a possible security breech last month I have had continual problems with my email and have had to go back online to reser my password, as my previous password was not working.  Are you still having problems with secrity breechs or is my account being continually hacked?

 

Becky

Email Expert

Re: Problems with email accesss

Can you clarify------exactly what happens when you try to get into your email?  Are you getting any error message?  Are you getting as far as the Inbox page or what?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Gold Problem Solver

Re: Problems with email accesss

I recommend that yiu call Comcast Security Assurrance and explain to them the issue you are having.

Comcast Customer Security Assurance: 1-888-565-4329 (M-F  6AM to 2PM.  http://security.comcast.net/get-help/contact-comca​st-security.aspx.





Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 2 replies
  • 246 views
  • 0 kudos
  • 3 in conversation