Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,840,974

members

1,231

online

35,960

topics

Top

Problems Sending Email

New Poster

Problems Sending Email

I have an ongoing problem with sending email. I havea MAC and using Outlook 

Gold Problem Solver

Re: Problems Sending Email

Please provide more details.  Are yiu getting any error messages?  If yes, copy/ paste the entire error message in your reply.

 

What settings are you using for email in Outlook?  Post all settings please.  Include which version of Outlook you are using?

Are you able to receive email if you use Xfinity Connect?

 

Which browser/ version are you using?  Have you cleared your cache?

CC



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 177 views
  • 0 kudos
  • 2 in conversation