Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,843,261

members

1,555

online

36,389

topics

Top

POP server email not sending or receiving - MANY people are still having problems

New Poster

POP server email not sending or receiving - MANY people are still having problems

Haven't been sending or receiving email on my comcast POP account via Mac Mail or on my iPhone6 for at least two weeks. There's no way to know when this started or how many emails I've now missed. IMAP email account seems to be working fine. No email for either account shows up on the Xfinity web site.

 

Called tech support 3 times now. Eash time I'm told something different, but the consistent message is that I'll get a phone call within 72 hours. That has not happened so I keep calling. As of tonight my issue has been "escalated" at tech service. Whatever that means. I'll tell you what's escalated - my blood pressure and my bank account from lost business.

 

Answers, please. Im hearing blameshifting to Apple from Xfinity but the other forums all point back to Comcast. FIX THIS!!

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 0 replies
  • 210 views
  • 0 kudos
  • 1 in conversation