Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,857,701

members

918

online

29,999

topics

Top

Outlook.com Can't Receive My Comcast Email Anymore

New Poster

Outlook.com Can't Receive My Comcast Email Anymore

My Outlook.com mail has been receiving and sending comcast emails for a long time, and it suddenly stopped being able to receive them.  Outlook.com can still send Comcast emails, but it can't receive them.  So I went in and made sure my settings were correct:

 

Server:  mail.comcast.net  Port 995  (the only other option for ports is 110 and that doesn't work either).  SSL is checked, and Leave a copy on the server is checked also.

 

Outgoing

smtp.comcast.net (port 465)  The only other port options are 587 and 25 --Neither of these work.

SSL checked. 

 

I've tried just about every combination, I continue to get the error message:

 

"There's a problem connecting to the SMTP mail server"

 

Has anyone found a solution to this problem.

 

Thanks very much.

New Poster

Re: Outlook.com Can't Receive My Comcast Email Anymore

Overnight, Apple mail could not send emails but could receive them. Got reommendation from Apple software friend to use 587 for outgoing server port number and 997 for incoming server port  number - SSL checked for both. That solved the problem ..... until an email came in, at which point the emails shown under "Mailboxes" on the the left disappeared .... and the incoming server port number change automaticelly to 110. Changing the number back to 997 restored the emails listed under "mailboxes" on the left. Again when a new email arrived the number automatically changed back to 110 and the emails listing disappeared again.

 

In the Preferences window for "Accounts" the box for 'Automatically detect and maintain account settings" was checked during this fiasco. Unchecking it did't help --- it just stopped anyemails from arriving.

 

At this point even changing the incoming port number to 997 does not restore the email listing on the left. 

 

Bleeping disaster. Other than not doing anything and hoping normal operations will be restored - anybody got an idea?

 

 

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 1000 views
  • 0 kudos
  • 2 in conversation