Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,857,691

members

526

online

30,005

topics

Top

Outgoing SMTP with MacMail stopped working

New Poster

Outgoing SMTP with MacMail stopped working

I have been using my Comcast's account outgoing mail server, smtp.comcast.net for several years to send email from various accounts on my iMac, Yosemite 10.10.4 and MacMail 8.2.  A few days ago, the outgoing server via Comcast stopped working. My gmail and godaddy accounts work fine.  Comcast outgoing mail server is set to 587 in Mac Mail. I've entered the user name and password at least 10 times. I've rebooted the machine.  The Connection Doctor with the Mac Mail is telling me that there is an incorrect user name or password for Comcast.  After ten times, I doubt that I messed it up 10 times in a row.

Email Expert

Re: Outgoing SMTP with MacMail stopped working

In Mac Mail you have to change the password for both the incoming and outgoing servers-------did you do that?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: Outgoing SMTP with MacMail stopped working

Correct.  Incoming mail is working fine with its corresponding password.

 

Outgoing - I'm tyring to continue to use smtp.comcast.net, but it won't verify the connection.  Under Outgoing Mail Server, I put in the user name and password for Comcast. The system then trieds to verify the information, but it comes back as Comcast (Offline).  It has worked fine for years, up until a few days ago. As far I know, nothing has changed on my system - although something has changed somewhere!

Email Expert

Re: Outgoing SMTP with MacMail stopped working

I'm using the same setup you are (I have an iMac), and I'm not having any issues with it.  But to clarify--------you're using the same password in both places, right?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: Outgoing SMTP with MacMail stopped working

Yes

Email Expert

Re: Outgoing SMTP with MacMail stopped working

OK what are the settings you are using for the smtp server?  Port #, SSL/TSL etc?  I would like to compare them to mine.  Here is what they look like-----------------

 

Screen Shot 2015-07-23 at 7.06.59 PM.jpg




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: Outgoing SMTP with MacMail stopped working

I am using Port 587 and SSL is checked. When I tried to set Authentification to None, it failed. I then selected Password Authentification and entered the same info that I do to log onto my Comcast account and that failed.  It had worked perfectly fine for almost 7 years and now I don't know what changed or why it's not working.

 

 

comcast

 

comcast 2

New Poster

Re: Outgoing SMTP with MacMail stopped working

Mac users are screwed.  You have to set up a new mail account and you will lose all your old email - ALL of it

 

Customer service is no help - "sorry we don't know what to do"

 

They should tell us when the SSL certificates are going to change and they are going to change servers !!!!!

Official Employee

Re: Outgoing SMTP with MacMail stopped working


blueone wrote:

Mac users are screwed.  You have to set up a new mail account and you will lose all your old email - ALL of it

 

Customer service is no help - "sorry we don't know what to do"

 

They should tell us when the SSL certificates are going to change and they are going to change servers !!!!!


Blueone,

We have not changed servers.  They are the same as they have been.  We have updated our SSL certs, but it has not proven to be an issue for any clients except Eudora (which hasn't been updated since 2006). 

 

I'm not certain setting up a new email account (within Mac Mail) is necessary, but if it is you can always create a new one and then copy all your folders and email to the new account.  No email should be lost.


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Official Employee

Re: Outgoing SMTP with MacMail stopped working


MikeBMike wrote:

I am using Port 587 and SSL is checked. When I tried to set Authentification to None, it failed. I then selected Password Authentification and entered the same info that I do to log onto my Comcast account and that failed.  It had worked perfectly fine for almost 7 years and now I don't know what changed or why it's not working.

 

 

comcast

 

comcast 2


I understand you haven't changed anything, but can you confirm the password you're using is correct by going to xfinity.com and logging in using the same UID and password?  


Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Official Employee

Re: Outgoing SMTP with MacMail stopped working


MikeBMike wrote:

I am using Port 587 and SSL is checked. When I tried to set Authentification to None, it failed. I then selected Password Authentification and entered the same info that I do to log onto my Comcast account and that failed.  It had worked perfectly fine for almost 7 years and now I don't know what changed or why it's not working.

 

 

comcast

 

comcast 2


 

MikeBMike -

 

Can you please private message me your username, so I can see check logs?

 

Private Messages (PM's)

At the top of each Forum page you will see a small envelope

This is the icon for Private Messages, referred to as `PM's'. A Private Message is a way to communicate in private, to another User, Moderator, or Administrator out of public view in the Forums.

The gray envelope icon will have a number next to it if you have any new messages waiting.

To open a PM to read it, double click on the envelope. If you click on the white envelope a window will open with tabs for your Private Message Inbox, Sent Messages, Friends, Ignored Users, and Compose new Message. You can also access this area by clicking on the Username in a Thread or post. By default, Private Messages are enabled. You can disable this feature in My Settings>Preferences> Private Messenger.





Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

New Poster

Re: Outgoing SMTP with MacMail stopped working

I am having the same issue!  Everything worked fine for years, then yesterday, I can't send email and am getting the same results you are.  Very frustrating.

 

 

New Poster

Re: Outgoing SMTP with MacMail stopped working

I've had this issue off and on for years on multiple Apple computers. Sometimes I get a dialog asking me to re-enter the password. Recently, I'm getting the Offline notice. Logging on to xfinity.com to access mail works with the same username and password. I tried creating another SMTP entry using a different (the main) userid and password with no better results.

 

It will work without issue for quite some time then, without me changing anything, it fails. At some point, it usually recovers, but my email is certainly less timely and not reliable.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 12 replies
  • 1036 views
  • 0 kudos
  • 7 in conversation