Xfinity plant
Xfinity globe
Community Forum

My E-mail address is shown as "Comcast"

New Poster

My E-mail address is shown as "Comcast"

When I send an e-mail to someone using my account it shows my e-mail address as "Comcast".  How do I correct this so my proper e-mail address is listed when they respond, etc?


Accepted Solutions
Official Employee

Re: My E-mail address is shown as "Comcast"

I believe you will find the first item in this help file should walk you through the steps you need to change your display name.

https://www.xfinity.com/support/internet/xfinity-connect-advanced-features/


All Replies
Expert

Re: My E-mail address is shown as "Comcast"

Assuming you are in the new email  format, open a Compose window from the Inbox page.  At the top where you see the From: address, click on the small black arrowhead to the right, and you will see the option to edit the outgoing name.

New Poster

Re: My E-mail address is shown as "Comcast"

I see a "to" a "cc" and a "subject"  I do not see a "from" anywhere on that page.  I was hopeful that would work but I don't see the from that you mention.

Official Employee

Re: My E-mail address is shown as "Comcast"

I believe you will find the first item in this help file should walk you through the steps you need to change your display name.

https://www.xfinity.com/support/internet/xfinity-connect-advanced-features/

New Poster

Re: My E-mail address is shown as "Comcast"

Okay, I was able to do that, so hopefully this solved the problem! Thanks!