Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,159

members

1,496

online

29,109

topics

Top

March 10, 2017 EMAIL issues

ANSWERED
Regular Visitor

March 10, 2017 EMAIL issues

After posting to the user forum yesterday and chatting with a Comcast employee about the issues with email for the last month, the issues today are even worse. Cannot get email to load at all. I assume engineers are still working to fix this server issue, as I was told yesterday. We have had sporadic issues with email for a month now.

Accepted Solution

Re: March 10, 2017 EMAIL issues

We've been having issues also,  two people in our office ended up with a differerent email format all together and suddenly one of those people is unable to find the SEND button on her email.  No one seems to know what the problems is.

View answer in context
New Poster

Re: March 10, 2017 EMAIL issues

We've been having issues also,  two people in our office ended up with a differerent email format all together and suddenly one of those people is unable to find the SEND button on her email.  No one seems to know what the problems is.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 464 views
  • 0 kudos
  • 2 in conversation