Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,164

members

1,474

online

29,110

topics

Top

It's the Weekend So New Email Problems

Contributor

It's the Weekend So New Email Problems

Here we go again.  When I attempt to sign in by clicking on the mail icon on the Xfinity homepage, as I always do, I sometimes get directed to an Xfinity Direct page with a blue background instead of directly to my mail.  When I click log on on this page it says try later.  I then exit out, try agin and usually get in to my email.  I also at times get the spinning colorful wheel; I use Safari.  Yes, I know I can download and use Chrome, etc, but Comcast should work with Safari too.  They have admitted that they have probles in this area.  Comcast is just awful.  The problems with their email just continue, and nothing gets solved.  

Email Expert

Re: It's the Weekend So New Email Problems

I am not having any issue with Safari.  Did you try clearing the browsing history, and then open it in a fresh session?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Regular Contributor

Re: It's the Weekend So New Email Problems

This just happened to me today, for the first time.  I cannot get into my e-mail, at all now. 

 

NOTE:  I found a great post by Forum Member   wymi  (his/her Forum screen name) posted in THIS Forum on March 16, 2017.    wymi captured that e-mail sign-in page in a screenshot.  Can you , please, look at THAT post and let everyone know if you are having the same problem as wymi and I are having.

 

AND, have you found a solution, yet??  If you have a solution, can you, please, share it.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 2 replies
  • 195 views
  • 0 kudos
  • 3 in conversation