Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,843,089

members

1,443

online

36,346

topics

Top

I can't receive emails, but I can send.

New Poster

I can't receive emails, but I can send.

I can't receive emails, but I can send. I was on the phone with them for 2 hours and still have received no answer.

Gold Problem Solver

Re: I can't receive emails, but I can send.

What are you using for email?  Which email program or device?

Are you using POP or IMAP?

 

Copy / paste the error message you are getting in your reply please.

 

Here are the settings for both POP and then for IMAP.

 

INCOMING SERVER: mail.comcast.net

Port: 995 with SSL ON

OUtgoing server:  SMTP.comcast.net

Port:  465 with SSL. ON

Under the Server tab:  This server requires authentication must be checked.

Do not check SPA (secure password authentication) at all.

 

IMAP SETTINGS

 

INCOMING SERVER: IMAP.comcast.net

Port : 993 with SSL ON

OUTGOING SERVER:  SMTP.comcast.net

Port: 465 with SSL  ON

This server requires authentication checked.

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 279 views
  • 0 kudos
  • 2 in conversation