Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,859,443

members

1,208

online

29,151

topics

Top

Email very very slow to open, why?

Frequent Visitor

Email very very slow to open, why?

I typed  my question in the wrong place so please bear with me.  I have a new computer running Windows 7 with Internet Explorer version 11, Full version, Xfinity mail why does it take so long to open each incoming mail message to read?  I  put off

going on my computer which results in more frustration caused more emails.  Sometimes I have to double click several

times to open mail.  I read other forums with people asking same questions no one was able to give them an answer

because they didn't give enough information.

 

Before I bought my new desktop I had Windows 98, Lite version, all incoming mail opened in a flash.  Now with everything

new I am singing the blues.  I detest reading my mail now.  Do I need to switch to a different email service?

 

Internet explorer closes down while I am reading a lengthy letter.  I've checked all my connections, followed all the

steps and it still happens why?  When I use Chrome the internet session never closes down.  Recently I replaced

my old Comcast moden with newer Xfinity moden. 

 

Lastly why am I not able to chose a color for my text and/or select a different font?  When I used Lite I thought I was

able to.  Now I don't know where to search to create a unique letter to send thru my email account with Comcast/Xfinitity.

I have never used Windows Live.

 

thank you for your patience, Colleen 

Gold Problem Solver

Re: Email very very slow to open, why?

With Internet Explorer Version 11, you must enable COMPATIBILITY VIEWwhich is located under the TOOLS tab at the top of your window.

Are you now using the Full or the ZliteLite version of Xfinity Connect? To check:

Open XfinityConnect, click on Preferences in the Preview window. Now click on the General tab. A window opens showing which version you are using.


You don't have your anti virus checking email? If yes,turnit off. Because a Comcast scans all email.

Post back.
CC



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Frequent Visitor

Re: Email very very slow to open, why?

Carole, thank you for your assistance.  I am using the "Full Version" and when you ask me to enable compatibility under

the tools menu do you mean leave it the way it is?  example: Box next to " Display Intranet sites".....has a check mark in it.

Box next to ,"Use Microsoft compatibility list". has a check mark in it.  Enable would mean check mark?  Disable meaning remove check marks?  Also says "websites you've added: Comcast.net" .

 

I am not aware of my email being scanned for a virus. I  never asked it to be checked. I know McAfee leaves a note on my desktop telling me I have no anti-virus covering the internet. I downloaded Norton per instructions from Comcast other security site no longer being used.

 

I've  never used the spam key or spam box offered by comcast.  Iremember reading from a forum answer also asking same question as I. Person wrote back the problem lays within Internet Explorer version 11.  I don't know what that means.

Anyway I'm writing you back..

 

Thank you.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 2 replies
  • 635 views
  • 0 kudos
  • 2 in conversation