Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,840,898

members

874

online

35,934

topics

Top

Email not working again

Contributor

Email not working again

This afternoon my problem with email is that when I click on the envelope or the sign in tab it just brings up a blank screen and not the screen to enter name and password.

 

I can go into my account and sign in to that but still not to emails. There is no error message or any indication that the system is trying to connect but cannot.

 

I do not want to be pushy but this is getting old as issues with email seem to be having every day for the past week.

 

I have cleared caches etc. tried different browsers and different computers and different email accounts all with the same results.

 

 

Contributor

Re: Email not working again


carapetunia wrote:

This afternoon my problem with email is that when I click on the envelope or the sign in tab it just brings up a blank screen and not the screen to enter name and password.

 

I can go into my account and sign in to that but still not to emails. There is no error message or any indication that the system is trying to connect but cannot.

 

I do not want to be pushy but this is getting old as issues with email seem to be having every day for the past week.

 

I have cleared caches etc. tried different browsers and different computers and different email accounts all with the same results.

 

 


I have found a work around at least for now with regards to this problem. I sign into the "my account" tab. Wait a few minutes and then the email envelope works. At least for one of our accounts.

 

I hope this helps technicians resolve the problem.

Regular Visitor

Re: Email not working again

I have the same issue, blank screen when using the envelope to try and access my email. Spent half an hour with customer care chat last night and NO help.

 

The work around I found was to log into "My Account" on the home page. That pops up their new account info page on a new tab and then I can click the envelope for my email.

 

They seem to have broken something as this started yesturday about 0830.

Frequent Visitor

Re: Email not working again

I was having an issue of not being able to get emails, but a differenct error message. So after 11 calls and being cut off three times, putting in a tickets and hoping someone called me back, I demanded to speak to a technical person. Who actually took the time instead of telling me "we are having some outages". After she reviewed my logon, it was determined that they had not activated my email account properly after their upgrade. She had it fixed within 30 seconds.

Email Expert

Re: Email not working again


carapetunia wrote:

This afternoon my problem with email is that when I click on the envelope or the sign in tab it just brings up a blank screen and not the screen to enter name and password.

 

I can go into my account and sign in to that but still not to emails. There is no error message or any indication that the system is trying to connect but cannot.

 

I do not want to be pushy but this is getting old as issues with email seem to be having every day for the past week.

 

I have cleared caches etc. tried different browsers and different computers and different email accounts all with the same results.

 

 


Did the phone rep suggest that you clear your browsing history?  If not you need to do that first.  Then restart the browser in a fresh session.  You could also try using a different browser.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Contributor

Re: Email not working again


Latoque wrote:

carapetunia wrote:

This afternoon my problem with email is that when I click on the envelope or the sign in tab it just brings up a blank screen and not the screen to enter name and password.

 

I can go into my account and sign in to that but still not to emails. There is no error message or any indication that the system is trying to connect but cannot.

 

I do not want to be pushy but this is getting old as issues with email seem to be having every day for the past week.

 

I have cleared caches etc. tried different browsers and different computers and different email accounts all with the same results.

 

 


Did the phone rep suggest that you clear your browsing history?  If not you need to do that first.  Then restart the browser in a fresh session.  You could also try using a different browser.


I appreciate you replying however I posted in my original post (see above) about all the things you are now suggesting.  According the technical support people I spoke to the issue (s) being experienced would not be resolved by this method. I have posted elsewhere my work arounds for the situation which began over a week ago elsewhere in the forums.

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 5 replies
  • 292 views
  • 0 kudos
  • 4 in conversation