Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,857,700

members

824

online

29,999

topics

Top

Email mailboxes won't load in FireFox

Regular Visitor

Email mailboxes won't load in FireFox

I've apparently got a setting wrong in FireFox as my email mailboxes won't load (it shows the word "loading" but never does) and I can't attach anything to an email I'm sending.  I'm sure it's a FireFox setting and not a Comcast setting as everything works fine if I use IE.  Can anyone give me any idea as to why that might be happening?

Email Expert

Re: Email mailboxes won't load in FireFox


Try clearing out The Firefox cache/browsing history. When you have done that, close it out and re-start it in a fresh session.  See if that does it for you.





Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Regular Visitor

Re: Email mailboxes won't load in FireFox

I tried that but it made no difference.  I have a feeling it might have something to do with an add-on or plug-in.  Do you have any idea what it is that allows that mailbox list to load?  I've tried downloading the most current versions of Java, JavaScript, Flash etc, but nothing seems to help.

Email Expert

Re: Email mailboxes won't load in FireFox

Try disabling your extensions or themes one by one and see if you can spot the culprit that way.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Regular Visitor

Re: Email mailboxes won't load in FireFox

I have disabled each one and then enabled each one.  I can find nothing that makes any difference.  I'm trying to compare my IE to the FireFox settings, but I can't find much difference.  My IE does show Java Plug-In SSV Helper and Java Plug-In 2 SSV Helper enabled.  I can't find those on FireFox.  Think that could be the problem?

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 4 replies
  • 300 views
  • 0 kudos
  • 2 in conversation