Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,841,181

members

1,483

online

36,016

topics

Top

Email Folder Disappeared with all the attedant emails

New Poster

Email Folder Disappeared with all the attedant emails

I chatted with an agent the other day. Looked through all the deleted emails for the past 60 days or whatever. None of the ones I need were there. I had a sub-folder with many important emails in it. One day it was just gone. I've had some problems with the Comcast cloud before but nothing this serious. I cm thinking that I iwll have to change where my emails are stored as I can't work with this unreliability.

Gold Problem Solver

Re: Email Folder Disappeared with all the attedant emails


capitano-bryce wrote:

I chatted with an agent the other day. Looked through all the deleted emails for the past 60 days or whatever. None of the ones I need were there. I had a sub-folder with many important emails in it. One day it was just gone. I've had some problems with the Comcast cloud before but nothing this serious. I cm thinking that I iwll have to change where my emails are stored as I can't work with this unreliability.


To search for delete emails:

 

Open the Inbox and TIGHT CLICK ON the Trash  Folder.  Click on Recover deleted messages

 

A window opens showing deleted emails, but not really old news.  If you see any that you want,

HIGHLIGHT those emails.

trash

Next click on the small green arrow on the top of the window.

A new window opens where you can move them back to your Inbox.

 

Folders:  To the right of the word MAILBOXES, there is a small faint arrow.  Clicking on the arrow should then show all Folders and Subfolders.

 

You can forward all email to a different email address in a different program,  or you can just not use XC, and start using a free email program such as Gmail, Thunderbird,Windows Live  Mail..

CC



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 287 views
  • 0 kudos
  • 2 in conversation