Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,861,062

members

1,474

online

29,458

topics

Top

E-mail

New Poster

E-mail

What is wrong with your mail system.  For the last month I have had trouble calling up my mail account.  I have to keep refreshing my screen and when I do finally get to my E-mail when I try to do anything the system tells me that comcast is not responding and I have to try to recover.  This is getting very annoying and time consuming.  What can You do to get Your system to work properly.  If You can't solve this problem possibly all should get another service.

Service Expert

Re: E-mail

This doesn't seem to be a widespread problem, or we would have heard about it here.

 

What browser and version are you using?  Have you tried another browser?  Have you installed any new software?  Updated anything on your end?  What is the EXACT error message you get when you try to log in to your email?

 

I am not saying there isn't a problem on Comcast's end, but we need a lot of information to try to help with your problem.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: E-mail

In answer to Your question, I am not getting a message.  I click on the e-mail it kicks over to the e-mail page and then sets there with little blue dots spinning around in the middle of the page.  Then when I hit refresh it does the whole thing over again.  When it finally give me my messages i click on one and it will come back and tell me that Comcast is not responding and a box to recover the page.  After a while it will let me read my message or do what ever I wish to do.

Email Expert

Re: E-mail


jstros123 wrote:

In answer to Your question, I am not getting a message.  I click on the e-mail it kicks over to the e-mail page and then sets there with little blue dots spinning around in the middle of the page.  Then when I hit refresh it does the whole thing over again.  When it finally give me my messages i click on one and it will come back and tell me that Comcast is not responding and a box to recover the page.  After a while it will let me read my message or do what ever I wish to do.



Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way. If it works OK then you will know the problem probably lies with the first browser. eg: if you are using Internet Explorer, try Chrome or Firefox.

If you are using IE 10 or 11, make sure Compatibility mode is enabled for comcast.net. You will find it in IE under "Tools".




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 3 replies
  • 443 views
  • 0 kudos
  • 3 in conversation