Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,845,008

members

870

online

36,687

topics

Top

Connect to email

New Poster

Connect to email

I have had nothing but problems since xfinity took over.  I have two laptops.  One 8.1 which seems OK but I also have a windows 7.  I see the email logo with our name but it just goes into a loop but never connects on the windows 7 laptop. 

 

Gold Problem Solver

Re: Connect to email

Which browser and version are you using?  Have you cleared your browser cache?  Clear it, then close and re-open the browser.

 

IF you are using Internet a Explorer:  a Click on Tools, then on InternetvOptiins...scroll to Compatibility  View and click there to be sure that a Compatibility View is on.

 

Have you tried another browser to test if tge issue is with the browser currently being used?

If using IE, try Firefox or Chrome too.



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Xfinity Forum Archive
About the archive project

Xfinity Forum Archive...

This is an archived section of the community.

Content in this area has been identified as outdated or irrelevant.

This change was done in an effort to make the forum easier to use and to keep only the most helpful and recent content active.

Post your questions in the Xfinity Community

Discussion stats
  • 1 reply
  • 289 views
  • 0 kudos
  • 2 in conversation