Xfinity plant
Xfinity globe
Community Forum

Blocking e-mails

New Poster

Blocking e-mails

How can I block certain senders, specifically "Linkedin". I have tried several times to "unsubscribe" but they have ignored my requests.

Expert

Re: Blocking e-mails

Assuming you are still on the old email format-------------

From your Inbox page, go to Preferences>>>>>>Email>>>>>>>>Email Filters. Click on that, and then follow the prompts to set up a filter for that sender. One of the options is "Discard", which dumps any emails from that sender and you just never see them.

If you are on the new format, click on the gear icon in the upper right corner of the screen, then on Settings. There you will see Filter Rules. Click on that and follow the prompts.

New Poster

Re: Blocking e-mails

There is nothing under "Filter Rules".  I am constantly dropping emails that I signed up for.  I will get them for a couple months then all of a sudden I don't receive them anymore and they are not in the "Spam" folder.  Can anyone help with this?

Expert

Re: Blocking e-mails


schmity5 wrote:

There is nothing under "Filter Rules".  I am constantly dropping emails that I signed up for.  I will get them for a couple months then all of a sudden I don't receive them anymore and they are not in the "Spam" folder.  Can anyone help with this?


You need to call Comcast security to see if there is a blocking issue with that sender's domain-------------------

 

Comcast Customer Security Assurance-------------------

Normal business hours (6:00 am to 2:00 am EST, 7 days a week)

1 - 888-565-4329

 

What do you mean by "nothing under Filter Rules"?