Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,844,622

members

1,159

online

36,627

topics

Top

Installed Arris SVG2482AC and activated, phone partially working

ANSWERED
New Poster

Installed Arris SVG2482AC and activated, phone partially working

I replaced my rented Arris TG1682G with my own Arris SVG2482AC tonight and followed the registration/activation steps.  All worked perfectly and I have Internet and Telephone connectivity.  I have dial-tone and can dial out on my phone line but the home phones are not ringing when called.  Thankfully I have always had it set up to simultaneously ring my cell phone so I can still receive calls but any thoughts on why my inbound calls aren't ringing through? 

Accepted Solution

Re: Installed Arris SVG2482AC and activated, phone partially working

Well the passage of another couple of hours seems to have resolved the ringing issue.

Phone working now.

Really should put on the self-install directions page a blurb about the lag in phone service activation.

View answer in context
New Poster

Re: Installed Arris SVG2482AC and activated, phone partially working

Well the passage of another couple of hours seems to have resolved the ringing issue.

Phone working now.

Really should put on the self-install directions page a blurb about the lag in phone service activation.

Tags (1)
New Poster

Re: Installed Arris SVG2482AC and activated, phone partially working

I'm looking to buy/upgrade from my Comcast rental Arris TG1682G, possibly to the the newer SVG2482AC to improve both the overall performance and use the voice service in my upgraded Blast Triple Play package. However I have two issues; the first is overcoming Wi-Fi range and deadspots (at least very inconsistent signal strength and disconnects now with the TG) and concerns about the history of bugs around the Intel Puma6 Chipset and its reputation for poor moden performance and support. My questions are, does the SVG in-fact have a superior WiFi range to address my deadspots, and is there any update suggesting the SVG does not suffer from the reported over last year?

New Poster

Re: Installed Arris SVG2482AC and activated, phone partially working

KKast - I can tell you that my SVG2482AC has been performing well since I installed it with no issues.  However, I too was having Wifi issues in my home and this alone did not resolve that issue.  I did end up putting in a LinkSys Velop 3 node mesh wifi system and putting the Arris in Bridge mode.  I now have the same excellent Wifi speeds throughout my multi-level home and am very pleased with it.

New Poster

Re: Installed Arris SVG2482AC and activated, phone partially working

Thanks and appreciate the prompt response...I was expecting at least an extender, if not mesh...just how my house is configured up and down, with walls and nooks. Good to hear connectivity with SVG is working out. Think that is the plan. Last question...where did you pick up the box, Amazon, BBuy,  or other...pricing?

New Poster

Re: Installed Arris SVG2482AC and activated, phone partially working

Got mine on Amazon. There was a $20 coupon offer at the time so $218. Good luck!
Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 5 replies
  • 515 views
  • 0 kudos
  • 2 in conversation