Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,872,805

members

1,167

online

28,841

topics

Top

Home phone not ringing

New Poster

Home phone not ringing

Home phone does not ring but I can see name and number on TV
Service Expert

Re: Home phone not ringing


@tedbarb wrote:
Home phone does not ring but I can see name and number on TV

Some phone manufacturers offer a SILENT option which can be configured on the phone.   What is the make/model of the phone with this issue?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

New Poster

Re: Home phone not ringing

We just got the land line phone working.  it worked well and still has excellent connection quality, but now it stipped ringing when calls are received.

I have checked all phones and it is the same problem.  At most there is a short ring and then nothing.

Most phones are VTech cordless of two different generations.  The newer one has the Bluetooth feature we are not using.  

The third type of phone is an old "princess-style" handset we keep in our "safe area" for storms and is used only in emergencies.

I can make calls from any phone.

It seems to be insufficient line voltage.  

The NEW ARis Modem is green on all indicators except "TEL".  "Line 1" and "Line 2" both are green, but the "TEL" indictor stays orange. I have reset the modem several times with the same issue.

 

My guess is insufficient line voltage, but would appreciate any ideas.

Special Events
FIFA World Cup 2018 on Xfinity See More
Discussion stats
  • 2 replies
  • 241 views
  • 0 kudos
  • 3 in conversation