Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,787,247

members

64

online now

1,937,746

discussions

Top

phone

Regular Visitor

phone

After installing the new modem, my phone no longer works. No dial tone and no "Tel"  light on the modem. Internet works fine.

Problem Solver

Re: phone

Use your cellphone or another phone:

 

Activating Your Equipment Over the Phone

 

  1. Call 1-855-OK-BEGIN (1-855-652-3446).
  2. While on the line for telephone activation, you will need:
    • The phone number associated with your account.
    • The last four digits of the equipment serial number(s).
    • The location of the equipment (living room, bedroom, etc.).
Administrator
Administrator

Re: phone


pl-martin wrote:

After installing the new modem, my phone no longer works. No dial tone and no "Tel"  light on the modem. Internet works fine.


What corgi11 suggested should be able to solve your issue. Have you tried doing this? 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon