Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,705,736

members

78

online now

1,869,551

discussions

Back to Top

no Advanced Call Forwarding in voice preferences

SOLVED
Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 6
1,367 Views

I recently moved my Xfinity service and had to get a new account and phone number. On my old account I used Advanced Call Forwarding to set up Nomorobo call screening. But in my new account, there is no Advanced Call Forwarding listed in my voice preferences, making it impossible to set up Nomorobo on my new number. How do I get Advanced Call Forwarding?

1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 4 of 6
1,325 Views
Solution

I figured it out. I had to install the Xfinity Connect app on my cell phone and activate Voice2go. Then when I went back onto the computer and logged into Voice Prefernces again, the "Call Forwarding and Rings" section morphed into "Advanced Call Forwarding" after a few tense seconds. The odd thing is I never had to do that on the previous number. I never had that app when I set up Advanced Call Forwarding and Nomorobo on the old number.

5 REPLIES
Posted by
Official Employee

Message 2 of 6
1,328 Views
If you have the new e-mail / voicemail system, you get to Advanced Call forwarding by going to xfinity.com, signing in with your primary username, clicking on the phone icon at the top right to get to voicemail, and then clicking on the settings cog at the top right. From there click on settings in the drop down menu, then choose the voice icon. You should see a forwarding option appear after the page fully loads.



Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 6
1,294 Views

What you are describing is exactly what I don't see. Here is a screenshot where I have expanded the call forwarding section:

Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 4 of 6
1,326 Views
Solution

I figured it out. I had to install the Xfinity Connect app on my cell phone and activate Voice2go. Then when I went back onto the computer and logged into Voice Prefernces again, the "Call Forwarding and Rings" section morphed into "Advanced Call Forwarding" after a few tense seconds. The odd thing is I never had to do that on the previous number. I never had that app when I set up Advanced Call Forwarding and Nomorobo on the old number.

Posted by
New Poster
  • Great Job! Your reply has been accepted. Thank you for helping and Congrats on your 1st Solution.
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 6
1,280 Views

Just for completeness here is the "After" picture, after activating Voice2go. I deleted the app from my cell phone, unchecked the Xfinity Connect Mobile App box (below), and added the Nomorobo number and my actual cell phone number (OTHER):

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 6 of 6
550 Views

I had a similar problem, in Voice settings, opening the Advanced Call Forwarding page resulted in a pop up error saying there was an error processing the request, log out and log back in and try again.  Of course that didn't help any.  Only after installing the iOS app 'XFINITY Connect' and using that to turn on Advanced Call Forwarding did the web configuration page work correctly.  I added Nomorobo then deleted the app and the forward to it as described above to stop all calls to my phone. Thanks for your help.  You saved me a call to support which might have proven fruitless.