Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,785,242

members

39

online now

1,935,954

discussions

Top

Turning off text messaging

Regular Visitor

Turning off text messaging

How do I turn off text messaging to my Comcast phone number? The xfinity app, in Text Settings, subscriptions options, teases you to think you can do it, but all it does is confirm that text messaging is active. This looks like a bug.  I have wasted far too much time navigating the web site(s) and from my mobile devices via the app, account settings, etc, etc. Very frustrating. 

Tags (1)
Silver Problem Solver

Re: Turning off text messaging

Hello,

You can not turn off the text message feature.

Regular Visitor

Re: Turning off text messaging

Not the answer I wanted, but thanks for the swift reply. I appreciate it!

New Poster

Re: Turning off text messaging

Can someone please change this? I don't want text messages coming to my home phone, I don't check them and then there are huge miscommunication issues. I hate to switch to a different provider over a simple "on or off" feature.

New Poster

Re: Turning off text messaging

Comcast/XFINITY,

I agree.  As a customer I would like the opportunity to turn off this feature.  I don't use it and it perpetuates the notion that someone is communicating with me (passively?) when they are in fact not.  It is generally accepted and well known that mobile phones are text capable and we use them accordingly.  Text capability on a land line is not needed.  It provides yet one more communication channel that I am forced(?) to check--because Comcast is imposing their will on me.  I need fewer and more efficient communication tools. . .not more.

Regular Visitor

Re: Turning off text messaging

Well said!

New Poster

Re: Turning off text messaging

Please allow customers to turn text messages off. 

Just found messages going back to Februaury that I didn't know existed. I do not want text messages going to my home phone.

New Poster

Re: Turning off text messaging

Same here! Please allow us to turn this OFF!!

Frequent Visitor

Re: Turning off text messaging

Mark, you can turn off the Text Message feature...

 

got the app that controls your preferences, and choose, notifications, and from there you have the option to turn off text messaging.

Frequent Visitor

Re: Turning off text messaging

Please log online into your account and go to "voice/text" and choose "prefences" and disable text.  

Regular Visitor

Re: Turning off text messaging

How do I turn this feature off? 

 

I *REFUSE* to download an app FIRST to my phone to turn off a feature that should be easily disabled by logging onto my home PC!

 

Thank you,

Les P

Aurora CO

Service Expert

Re: Turning off text messaging


lessp wrote:

How do I turn this feature off? 

 

I *REFUSE* to download an app FIRST to my phone to turn off a feature that should be easily disabled by logging onto my home PC!

 

Thank you,

Les P

Aurora CO


 

Call into Comcast @ 1-800-266-2278 and speak with a CSR about the possibility of DISABLING the Text Message Feature.



The Support Forums are "public" forums and you should not post identifiable information - (full name, account number, address, phone numbers & email addresses).  Users of these forums are Comcast customers, the same as you & me and volunteer their time to assist with the issues and/or problems that you may be experiencing.  Please ensure your post is in the correct Forum to begin with.   Please do not send me Private Messages for personal help but instead use the Forums to allow everyone to read and offer comments to assist you. 
******* Comcast Official Employees (OE) are identified with
RED lettered User Names. *******




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Turning off text messaging

I don't have an answer, but I am also trying to turn off texting to my  XFinity phone number!!

Very frustrating and I am missing texts.  Texts to that number are always sent in error and the sender assumes I will get it and respond quickly!!

 

 

 

 

Frequent Visitor

Re: Turning off text messaging

I probably should have made myself clear, not an actual APP as in download like for a pnone application. 

Its located on your preference choices where you select how many numbers you block, etc. 

Frequent Visitor

Re: Turning off text messaging

Just go open Email and click your "Preferences" tab  and click "Text Messaging" and then disable.  Problems should be solved. 

 

 

Regular Visitor

Re: Turning off text messaging

Les, are you talking about on the xfinity iOS app? I tried that, and all it does is turn off the alerts of the texts, not the actual functionality of texting to the land line. Am I missing something?

Frequent Visitor

Re: Turning off text messaging

Mark,

 

No, not the ios app.  When you open your email box, reading your mail, you'll see at the top "Email, Voice, Address Book, etc.  when you click "preferences" open up the Text Messages icon, choose edit and then disable.  That disables the functionality to the landline.  

 

Let me know if that helps  

 

 

Frequent Visitor

Re: Turning off text messaging

Mark,  

 

You might want to perform this task on your PC/laptop/tablet.   Just a thought

New Poster

Re: Turning off text messaging

I am doing this on my computer and the only choices I have to disable are: forwarding and audio notification.  Nothing that allows me to disable texting to my number.

 

Frequent Visitor

Re: Turning off text messaging

You need to be in your email, and there are preference tabs across the top and read as follows:

 

Email - Voice - Address Book - Calendar - Text Messaging - Preferences - Help.  

 

You will want to go into the tab "Preferences" and chose the "text message icon.  From there you will be given 3 option, you want to chose the first one that allows you to disable your text messaging from being forward to your home phone.  

New Poster

Re: Turning off text messaging

Thank you for the reply but when I try that, I'm only presented with two options and neither give me the ability to turn off
Frequent Visitor

Re: Turning off text messaging

From my prior email...choose "forwarding" after you have done all the other task, then once you have click on "forward" it will allow you to disable your forwwading text messaging.  You will have an option to the right to "edit"... the screen should look like this after you click on the Preference tab, and the Text Messageing Icon, you will see the following:  

 

Forwarding                       text messaging is xxxxxxx                                                        EDIT

 

Plan Option                      you can subscribe or discountine your service at anytime        EDIT

 

AUDIO NOTIFICATION    audio notification is xxxxxx                                                        EDIT

 

 

It is here where you will choose "forward" and then you will see where you have the option to disable the text messaging feature.   

New Poster

Re: Turning off text messaging

What's interesting is, I do not have that Plan Option. 

 

HOWEVER, when the page is loading, for a split second, I can see that option there, but it disappears when the load is done. So, I guess Comcast does not want me to turn it off.

 

 

New Poster

Re: Turning off text messaging

I kept playing around with the refresh of the page, until one time I got the Plan Options to appear. This is what I saw:

 

 

So, I chose 'unsubscribe'. and the text option appears to have been removed.

 

THE PROBLEM: Text messages sent to my number now are NOT bouncing. No rejection notice is sent. They just disappear. This may, in fact, be worse.

New Poster

Re: Turning off text messaging

Indeed, the page is doing its best to try to hide the ability to disable texting.

 

I had to use the 'Inspector' feature in my browser (F12 key) to edit the source and make the option visible (find 'style="display: none"' and delete). This then reveals the 'Plan Option' section and the ability to unsubscribe.

New Poster

Re: Turning off text messaging

Looks like you need to disable the Voice2Go feature, it is availble in both the mobile app and the website...

New Poster

Re: Turning off text messaging

the only options are:

 

Text message forwarding is
Audio notifications are
 
Plan Option is no longer an option available.  I called COMCAST  and they confirmed this. Their solution was to disable the alert on the Connect App by going into Settings then Notification Preferences then Messages:Text
New Poster

Re: Turning off text messaging

Doing that only turns off the notifications for text messages. I really think we should be able to turn the text feature off if we want to.

New Poster

Re: Turning off text messaging

Les only 2 options appear: forwarding and alerts.  I understand I am replying 1.5 years after your post but i just want to confirm that the ability to disable text messaging to your landline is not available, at least for me.

Service Expert

Re: Turning off text messaging

 

1 1/2 Year Old Thread being closed.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon