Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,787,147

members

24

online now

1,937,610

discussions

Top

Tel service not working

New Poster

Tel service not working

My telephone service is not working.  I have reset the modem, still no good.  I can call out but cannot receive calls.  (oh yea, and my account is current!)

 

Cable Expert

Re: Tel service not working

Contact Comcast support as this is mostly a user to user forum.

 

1-800-266-2278




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: Tel service not working

I do not have a dial tone. My light is flashing on my modem.
New Poster

Re: Tel service not working

The flashing TEL light on the modem is usually an indication that the line is in use.  ANYTHING within your home that is connected to the telephone jacks that end up being connected to the Comcast router can cause this situation if that something is stuck in the active mode.  It could be a cordless phone, answering machine, caller ID box, FAX machine or any other device plugged into any jack that is connected within your home.

 

Try unplugging the plug from the TEL 1 jack of the router and plugging your telephone directly into the TEL 1 jack of the router.  If it works, the problem is somewhere in your home as described.  Unplug all devices in your home and try reconnecting them one at a time to discover which one causes the problem.  It could also be a pinched wire or bad jack.

 

 

If plugging the phone directly into the router doesn't solve the problem,  you may have a bad phone or router.

 

Good luck