Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,789,238

members

79

online now

1,939,203

discussions

Top

Nomorobo Blocking ALL Calls

ANSWERED
Regular Contributor

Nomorobo Blocking ALL Calls

I mushed through all the instructions to setup NOMOROBO. I confirmed that I set it all up properly - I have the 202 number set in my Advanced Call Forwarding section in Xfinity. It is the ONLY number I have active in that seciton. I set up the Voice2Go on my Android phone. I clicked onthe NOMOROBO link to "TEST" the feature & was told it is working correctly. However EVERY phone that call my land line goes directly to VMAIL. I emailed Nomorobo support - but they are unresponsive! 

 

Has anyone actually been able to get this to work?? Are there errors in the SETUP or is this just a lousy feature that doesn't work?

Accepted Solution

Re: Nomorobo Blocking ALL Calls

I got this thing figured out ! The issue is the XFINITY documentation is not clear. WHen you set up the "Advanced Call Forwarding" and add the Nomorobo phone number (202...),  you MUST include your landline phone number. I had ASSUMED, based on the documentation, that you only ADD the Nomorobo phone number & uncheck all others. Wrong. You must ADD & Check your landline number.  (COMCAST - you really should make this more clear in your documentation!)

View answer in context
Regular Contributor

Re: Nomorobo Blocking ALL Calls

I guess this should have been under the VMAIL part of the forum - I didn't see that as an option when I posted this. If the Moderators wish to move this to that forum section, please do.

Regular Contributor

Re: Nomorobo Blocking ALL Calls

I got this thing figured out ! The issue is the XFINITY documentation is not clear. WHen you set up the "Advanced Call Forwarding" and add the Nomorobo phone number (202...),  you MUST include your landline phone number. I had ASSUMED, based on the documentation, that you only ADD the Nomorobo phone number & uncheck all others. Wrong. You must ADD & Check your landline number.  (COMCAST - you really should make this more clear in your documentation!)

New Poster

Re: Nomorobo Blocking ALL Calls

This is correct, you must include your home phone number. Don't try to get help from Comcast, its just a huge waste of time. They know very little about there own product and give bogus and incorrect information. Today I got a call from a Comcast tech trying to help out. She claimed I didn't have call forwarding set up and told me how to do in using the phone. OMG how does this company stay in business?

 

Anyway here are my settings. They work. And I am using the Xfinity digital phone service.

 

nomorobo_setup_comcast.png