Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,789,363

members

87

online now

1,939,328

discussions

Top

No dial tone, all lights working except link

ANSWERED
New Poster

No dial tone, all lights working except link

I have reset the modem 20-30 times, the only light that will not reset is the link light. When this started we also lost our internet connection and most of our HD TV channels were also not working. The only thing that has not reset is the phone. Is there another step I am missing to get the link light to reset?

Accepted Solution

Re: No dial tone, all lights working except link

 Thank you everyone for all of your help. I did another reset, this time pulling the battery, and it finally reset. It turns out the link light is not needed with my setup. The problem was either the modem was not resetting properly or Comcast...

View answer in context
Silver Problem Solver

Re: No dial tone, all lights working except link

take the battery our of the modem, unplug it and the line from the wall to it.   plug the line back in and put the battery in and plug it in.  If it does not come back call comcast.

Problem Solver

Re: No dial tone, all lights working except link

The link like is the ethernet connection to your router or PC.   Normally it lights up if the ethernet is plugged in.  Check if the ethernet cable is plugged into the PC or router and that the PC or router is switched on.

 

Some of them light up orange if you have 100MB ethernet and green if you have 1GB ethernet.

Problem Solver

Re: No dial tone, all lights working except link

There is also a light called online which is for the interface to the cable company.  The online light is one when the modem is connected properly to the cable head end and has an IP address for the internet sevice.

 

The lights turn on in order of DS (down stream) when it senses a stream from the cable company to you, this is like a tv tuner and it changes channels till it finds the internet on one channel,  once it gets information on that channel it does US (up stream) and tries to connect on the upstream channel.

 

Then it does things like DHCP to the head end to get a private IP address for management of the box.  It downloads the topology.  This lets it change from a single channel to multiple channels downstream.

 

Then it tries to register the modem once it gets to that phase it blinks the online light.  Once it gets registered and has ip (for the link) it turns on the online light.

 

Connection Expert

Re: No dial tone, all lights working except link

FWIW, barring any hardware or line / connection quality issues, a modem will achieve block sync mode (online light solidly lit) before it has yet been provisioned for service by them.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: No dial tone, all lights working except link

 Thank you everyone for all of your help. I did another reset, this time pulling the battery, and it finally reset. It turns out the link light is not needed with my setup. The problem was either the modem was not resetting properly or Comcast...

Problem Solver

Re: No dial tone, all lights working except link

The voice voice/internet modems are reset by pushing a button in the back with a pen or paper clip, you can't reset them by unplugging them because of the battery backup.  Were you pushing that reset button?

Connection Expert

Re: No dial tone, all lights working except link


cjerian wrote:

The voice voice/internet modems are reset by pushing a button in the back with a pen or paper clip, you can't reset them by unplugging them because of the battery backup.  Were you pushing that reset button?


FWIW, they can also be powercycled / reset using the method suggested earlier in this thread by this poster;

 

http://forums.comcast.com/t5/Voice-Service-and-Equipment/No-dial-tone-all-lights-working-except-link...




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon