Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,787,176

members

45

online now

1,937,670

discussions

Top

Land line not working

New Poster

Land line not working

When I run a check of all of my services it says everything is fine. However, I do not have land line service! My calls will ring in but I can't hear anything and no one can leave a message. (They can on voice service but not on my personal recorder). I also do not have a dial tone.

 

Both of my phone lines are flashing on my modem. What do I need to do?

 

Thank you.

Regular Contributor

Re: Land line not working

Did u ever have dial tone coming out of the box.. Or new install
New Poster

Re: Land line not working

After watching the comcast video on reseting the modem, I tried that and now everything is working fine.

I have never had that happen before. I never knew there was a reset button on the back. Thanks for the assistance and I hope everyone else finds their fix as easy as mine was.

New Poster

Re: Land line not working

OUR PHONE SERVICE HAS BEEN DOWN FOR TWO DAYS.  WE CANNOT CALL OUT AND NO ONE CAN CALL IN.  THERE IS STATIC ON THE LINE.  WE NEED THIS FIXED ASAP.  I BOUGHT NEW PHONES AND THOUGHT THATR WAS THE PROBLEM .  IT WASN'T.  PLEASE HELP FIX THIS PROBLEM

New Poster

Re: Land line not working

I TRIED TO RESET THE MODEM AND THAT DID NOT WORK EITHER.  I WILL CALL TO SPEAK TO SOMEONE AND REQUEST A TECH TO COME FIX THE PROBLEM.  THANK YOU.

Regular Visitor

Re: Land line not working

I have the same problem. Does anybody out there have a direct simple solution?
Regular Visitor

Re: Land line not working

Ditto ! How do you reset the modem?
Regular Visitor

Re: Land line not working

Help. I have the loss of Service problem too! Any body know what to do?
Regular Contributor

Re: Land line not working

Are all the lights on the box blinking, if so it's either a short or equipment issue, easy way to find out, unplug the equipment making sure all the lights go out, if they don't there is a backup battery in the bottom, remove the battery. Also unplug the phone chord attached to the equipment. Plug the power back in, leaving phone unplugged, if all the lights are solid it's a short in the phone wiring, u could plug a phone directly to the equipment, as a temp fix , but if you want all your phone jacks to work you need a tech