Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,785,090

members

64

online now

1,935,862

discussions

Top

Home Phone

New Poster

Home Phone

Ever since we installed the new xfinity modem we have no home phone service (503-297-1115).  If the TV is on we can see that someone is trying to call but none of the phones work.   I am sure this is user error on my part but I don't know where to start to correct the problem.  

Official Employee

Re: Home Phone

First edit your post and delete your phone number so no crazies are calling you.
On the front of the modem you have a tel 1 light is it flashing or solid?
On the back you have a tel 1 port that's where your phone line is coming from, do you have a phone you can plug directly into it.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon

Regular Contributor

Re: Home Phone

You should make sure that the phone cord going from the modem to the phone is secure and you might want to try using another phone cord.  If you can still answer the call, but the problem is the ringer, the ringer might be off on the phone.  You might also try rebooting the modem and trying a different phone.

 

If these steps do not work, you should give Comcast a call and have them check your account and that your modem is compatible with your account.  If you never called in or went online to activate your modem, that is most likely your problem.