Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,635,931

members

24

online now

1,813,794

discussions

Back to Top

Caller Id not Working on HD boxes

SOLVED
Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 11
2,511 Views

I contact Comcast earlier to let them know that Caller Id was not working on one of my HD boxes but it was working fine on the other.  They issued a reset signal to the non-working box and it took about 1 hr to reset.   Now it does not work on either of my boxes.

 

10 REPLIES
Posted by
Cable Expert

Message 2 of 11
2,510 Views

Unplug - wait 30 seconds - replug both of your boxes to reload the interactive applications.

 

Give it 2 hours before you test it.  It will take another 24-36 hours for your full guide to reload.

 

If they still don't work, then come back here tomorrow and it will be escalated to the Comcast Corp team that will follow up to get your caller id's back working.

 

If the reboot doesn't do it, then it is an account issue.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 11
2,505 Views

I tried on both HD boxes this morning.. Tried one then 2 hrs later tried the other.   The 1st unit now has Caller ID working.  This is the unit that had worked last week.   The 2nd unit still does not work.  The 2nd unit is a newer DCX 3400 HD/DVR that I picked up at Comcast last week.  The guides on the 2nd unit still do not show up (not complete anyway) but your earlier reponse indicated that it might take 24 hrs for those to completely reload.

Posted by
Cable Expert

Message 4 of 11
2,503 Views

If the new DVR doesn't start working on the caller ID by Monday, then please post back and the Comcast Corp administrator will be notified to look into the relationship of your new DVR with your account.  He will get it working if it doesn't come up on it's own.  There is always a few day delay on new equipment getting found on all the backend systems.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 11
2,496 Views
Posted by
Cable Expert

Message 6 of 11
2,494 Views

The Comcast Corp escalation team has been notified of your on screen caller ID issues and will get you fixed up.

 

Please watch this post and you email for updates from the team and if they need more information from you.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Retired Administrator

Message 7 of 11
2,490 Views

Hi mikecy - I'd like to work on this with you before moving further. I just moved a few things around on your account - can you please tell me what you are seeing?

Just 'Dete'
Retired Help Forums Admin



Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 8 of 11
2,488 Views

At this point I do not see anything on the HD/DVR box.  No Universal Caller Id, no error message or no message of any sort.  The other box is displaying Universal Caller Id ok.

Posted by
Retired Administrator

Message 9 of 11
2,526 Views
Solution

Thanks for confirming - I will have someone reach out to you today to discuss having the unit replaced if needed. We may need to have a tech out as well.

Just 'Dete'
Retired Help Forums Admin



Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 10 of 11
2,468 Views
Posted by
Connection Expert

Message 11 of 11
2,462 Views

mikecy wrote:

It's working now.


Good!  Please post back if it goes down again.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon