Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,787,660

members

33

online now

1,938,001

discussions

Top

Caller ID not working properly

Regular Visitor

Caller ID not working properly

I switched to CDV over a month ago and my caller id has not worked properly from day one. I onlly get the numbers but NO NAMES showing up on my phone when a call is received. I have called Comcast 18 times and spoken to 14 different people and to a T they all tell me the problem will be fixed in 24 hours. I am now in my last ditch effort to get the problem corrected by voicing a complaint to the Comcast Executive Complaint Center. If it is not fixed in 4 days I am going back to BellSouth. Any thoughts from anyone?
Regular Contributor

Re: Caller ID not working properly

Hi lyncher,

I did some checking on your account and it looks like our technicians did some preliminary troubleshooting and didn't find anything wrong. We have reassigned the problem to a more senior technician to review the problem more thoroughly.

I would also like to make sure that we have both the make and the model of the telephone or caller ID unit you are using. You can post that information in this thread or send it to me in a private forum message and I will pass that information along to the technician working on the case.

In the meantime, there are a few steps you can try on your own:

•  Try clearing the memory on the caller ID unit. In most cases, this would involve disconnecting it from the electrical power and the telephone line and removing the batteries in the unit (if any). You can consult your owner's manual for more details.

•  Try using a different telephone or caller ID unit and see if that fixes the problem.

Thanks very much for your patience while we get this worked out!

Geoff

Regular Visitor

Re: Caller ID not working properly

Hi Geoffg:

Thank you for your reply. I have submitted all the information on 4 of my phones to your tech people and gone through the suggestions you gave many times. All to no avail. All of my phones have had no problem at all in 7 years with BellSouth. The problem is definately with Comcast. As I stated I want to stay with Comcast but if they can not correct the problem in a week or so I will be going back to BellSouth.
Regular Contributor

Re: Caller ID not working properly

Hi lyncher,
 
I'm sorry if I was covering territory that you've already been over. When we're troubleshooting some of the more exotic problems we just have to make sure that all of the basics are out of the way.
 
As I mentioned in my previous post, we have a more senior technician looking into this problem right now since none of the usual fixes appear to be working. I will be in contact with you directly as soon as we have more information to share.
 
Thanks again for bringing this to our attention.
 
Geoff.
Regular Visitor

Re: Caller ID not working properly

Hi Geoff:

I have heard mixed reports about the Caller ID problem in Charleston and the protocol problem with BellSouth. Can you give me a definitive answer if you know 100% whether this problem has been fixed or not. If you remember the problem was that BellSouth would not release the names so when a call came in all you received was the number which was useless. Thanks.
Regular Contributor

Re: Caller ID not working properly

Hi lyncher,

First of all, let me get everyone up to speed with what the problem was:  when Comcast customers called someone who had telephone service with Bell South, our customer's name would not appear on the caller ID.  The problem lay on the Bell South side, but for a variety of reasons, they were unwilling to proceed with a fix until after their merger with SBC (now AT&T) went through.

As you all probably know, that merger has now completed.  According to the records I have looked at, that problem should now be fixed.  I am not sure if the reverse problem that you were describing (i.e. Bell South customers' names not appearing on Comcast customers' caller ID) has also been resolved.  Andrew and I will be checking with the technician who was coordinating our response to this problem to find out if everything is now working as it should and we will post here again once we have the definitive answer.

Thanks for bringing this up.

Geoff.