Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
New Visitor
Member Since: ‎06-26-2013
Posts: 1

Xfinity WiFi

Hello,

I am having issues with my new Xfinity wireless connection on all of my laptops. I can be sitting 30 feet away form the base unit and my wireless signal goes form full 5 bars to 1-2 or drops all together. If it drops, I have to do trouble shoot option to restore it. this is hgappening on all laptops.The di8stance never changes from lapotop to Wireless base unit, but anywhere from 1 minute to 30 minutes and it will lose connection. My computer either run Windows 7 or Windows 8. I have been on with Dell for all computer and find nothing wrong with computers. I also need to reset the Xfinity modem/router/phone (arris TG862) as I can't login to it now. I was going to to off the xfinity hot spot option to see if this fixes it.

regards,

Ed Ghiorso

Posted by
New Visitor
Member Since: ‎07-01-2013
Posts: 1

Re: Xfinity WiFi

I have the same issue. I think this is because the router/modem that we got from Comcast is not powerful enough like the ones from LinkSys. Depends on its range. I am planing to call comcast to replace it with a more powerful one. 

Posted by
Silver Problem Solver
Member Since: ‎02-22-2007
Posts: 6,127

Re: Xfinity WiFi

Hello,

It is known that comcast gateways are lousy. Get your own wireless router and you will be a lot better of.

Posted by
Connection Expert
Member Since: ‎12-24-2003
Posts: 46,924

Re: Xfinity WiFi

The above poster failed to add that if you do want to "use your own router" that you need to call in and have Comcast put your combo gateway device in to bridge mode so that it acts as a straight cable modem with which you use your own router so that you don't have any double NAT'ing issues associated with the cascading of two routing devices.