Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,465,122

members

8

online now

1,689,990

discussions

VPN not working

Posted by
Visitor
  • Congrats on Posting your first topic!

Member Since: ‎03-31-2012
Posts: 1
Message 1 of 4 (2,457 Views)

VPN not working

Hello...I just switched from business class to xfinity and my vpn no longer works.  My laptop worked fine with the business class modem.  I does not work with the new modem comcast installed.  The new modem is an Arris 602G.  I am sure its the modem blocking my vpn because I can vpn with my laptop using any other hotspot.  I cannot vpn in using the Arris 602G modem.  I even connected directly to the 602G modem with an ethernet cable.  I still could not get a vpn connection.  Has anyone else seen this problem?  Is there a fix?

3 REPLIES
Posted by
Networking Expert

Member Since: ‎07-28-2003
Posts: 24,240
Message 2 of 4 (2,453 Views)

Re: VPN not working

The issue is likely NOT the modem.  What router are you using, if any?  Make sure whatever router you use allows VPN passthrough for the type of VPN you are using.  Some routers may require certain port forwarding and/or other options set for VPN traffic to work properly, like disabling IP Flood detection, IPSec or L2TP passthough, etc.

 

If your laptop when direct connected to the modem talks to the Internet, but won't work with the VPN, but does in some random hotspot, but look to your VPN servers settting, there is likely some kind of block there.

 

But just on the off chance there is something wonky with the modem, disconnect it from ALL cables (power, ethernet, coax, phone), pull the batteries (if your model has 2 battery packs, pull them both), and let the device sit overnight.  Replace the batteries, connect the cables and try again.

Posted by
Connection Expert

Member Since: ‎12-24-2003
Posts: 51,230
Message 3 of 4 (1,416 Views)
Posted by
Connection Expert

Member Since: ‎12-24-2003
Posts: 51,230
Message 4 of 4 (1,415 Views)

Re: VPN not working

Year old thread closed.