Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,980

members

14

online now

1,954,657

discussions

Top

xfinity email via Outlook 2010 - Secure connection to the server cannot be established

Regular Visitor

xfinity email via Outlook 2010 - Secure connection to the server cannot be established

I have been a long time MS Outlook user via xfinity. Ever since the Windows 10 update on 10/6/2017 I have not been able to get the xfinity servers to respond. Always ending with xfinity server issues. I have spent a very long time in CHAT and despite that effort, it still remains a problem for me. The CHAT tried sending emails to my gmail and mail.com addresses that never showed up on my end. Copies of my setup and error responses are attached. This is pointing to xfinity as the server problem. My CHAT session went through the whole same process and it failed /again, and again, and again. Does anyone have any suggestions on how to get xfinity email to work again? Can anyone help?
Email Expert

Re: xfinity email via Outlook 2010 - Secure connection to the server cannot be established

Does the webmail interface work OK?  What settings are you using in Outlook for the Comcast account?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Regular Visitor

Re: xfinity email via Outlook 2010 - Secure connection to the server cannot be established

I am able to access my email via the web based email but that does not resolve the Outlook issue.  I included the Outlook settings as .PDF attachments to my original message.

Email Expert

Re: xfinity email via Outlook 2010 - Secure connection to the server cannot be established

All the pdf shows is this-----------------

 

Screen Shot 2017-10-03 at 7.22.52 PM.jpg

 

 

That is not what I mean;  I mean what are the actual server settings for incoming and outgoing emails?  The name of the incoming server, and the port number?  Same for the outgoing?  Security settings? etc.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: xfinity email via Outlook 2010 - Secure connection to the server cannot be established


Like wise. I have Windows 10 and Office 365 which uses Outlook 2016. For the last 3 weeks I have been going in circles with comcast & MS. Tonight I was able to prove that it is their network that prohibits me from running my gmail accounts on Outlook. The comcast mail works fine, but the gmail stopped working months ago. I shut off my Xfinity connection and booted up a hotspot from my phone and it all loaded up in seconds, thus proving that it is the Xfinity network! It is not MS as the Comcast rep wants you to belive.

Then to boot, they called me back as requested for a service follow up survey, and when I answered the phone, noone was there nor a recording - dead air! They DONT want my survey as it wont give them the results to show that they only want you to see. I do not hold the reps at fault, asthey are nothing but a pawn and have no idea as to the game that their company is playing with the public. I'm thinking of just dropping them totally and get my internet through my phone provider.