Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,637,202

members

10

online now

1,815,014

discussions

Back to Top

user name or password invalid on mail.comcast.net

SOLVED
Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 5
2,653 Views

I have two iPhones, a 3G and a 4.

I am trying to set up email on the 3G.

Here's the problem.

If I use one of my comcast accounts it works fine.

If I use the second account it get a "Username or password incorrect on mail.comcast.net" message.

 

I have verified the account is valid by logging in to www.comcast.net, m.comcast.net and smartzone.comcast.net.  I can log in fine and there are emails there.

 

I've tried it on both phones and get the same result.

 

I can set either phone to the first account and it works fine.

 

I've tried power cycling the phone, turning the account off and on, verified the username and password several times, tried the incoming server as mail.comcast.net and pop3.comcast.net, tried ssl on port 995 and no ssl. 

 

I've tried setting the phone to the first account, verifying that it works, and then changing the username and password to the second account without changing the other settings.

 

If I ignore the errors and set up the account anyway and then try SENDING an email, it sends fine.

Gets to the recipient intact with the correct senders address.

If I reply to it, it goes to the correct account and I can read it online.

 

I've tried all of these things on both phones.

 

Nothing seems to work.

 

What else can I try?

Thanks

4 REPLIES
Posted by
Mac Expert

Message 2 of 5
2,645 Views

If you have successfully set up an account on one phone, I guess we can assume you know how to configure an iPhone correctly for a Comcast email account Smiley Wink

 

What I would do on the problematic phone is delete the account the account and start over. Ensure all info is entered correctly. Outgoing info: smtp.comcast.net; Port 587; SSL ON; Password Authentication. Incoming info: mail.comcast.net; Port 995; SSL ON; Password Authentication. Watch that iPhone doesn't auto-capitalize any characters when entering your password.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 3 of 5
2,638 Views

Been there, done that.

No Joy.

 

:-(

Posted by
Mac Expert

Message 4 of 5
2,737 Views
Solution

How about if you try resetting the password on the problematic account in Account Management (click Manage My Account under Customers in the blue bar above, login again, then click Users & Settings). Go there and set a new password on the account, reconfigure the iPhone, then try and send yourself a message. We've seen users have similar issues occasionally with desktop-based email clients. It's worth a try.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 5 of 5
2,624 Views

That did it.

Thanks for the help.