Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,809,996

members

56

online now

1,955,210

discussions

Top

ssl_error_bad_cert_domain on Firefox

Most Valued Poster

ssl_error_bad_cert_domain on Firefox

I ran into this error this morning...well over 4 years since Andy's original post. I assume someone made a mistake during the cert renewal process.

Official Employee

Re: www.comcast.net

Hi, rardin - Are you still getting the certificate error? Did you get the same error message in a different browser? 




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Most Valued Poster

Re: www.comcast.net

Sorry for the late response, Ella.  The behavior was the same in different browsers on multiple platforms, but the problem went away eventually.

New Poster

Re: www.comcast.net

I too often get the the SSL_ERROR_BAD_CERT_DOMAIN error and it is very frustrating. It happens with www.gmail.com, www.google.com, and many other sites. It usually lasts about 1 - 3 hours and then it magically works. I it is now happening with www.jeep.com.     It always happens with both Firefox and IE with 100% correlation. It occurs with my iPhone browser on my phone (via wifi). Then if I turn my phone's wifi off (to use Verizon data) it works. e.g. Right now www.jeep.com fails using wifi/comcast on my phone and when I turn off wifi on my phone the same website instantly works.So clearly this is comcast related issue.

 

I have 'reset' Firefox and ran the latest CC cleaner on my PC. No luck.

 

For www.jeep.com I am getting this detail:

The certificate is only valid for the following names: *.korrelate.net, korrelate.net

 

Anything suggestions?