Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,910

members

60

online now

1,953,756

discussions

Top

out of country domain blocking

New Poster

out of country domain blocking

I am using Incredimail 2.5 on Windows 7 Ultimate machine.  I am currently using Firefox 45.0.2 as a browser.

I do NOT have a smartphone and my account is a POP3 account

 

Is there any “simple” way of blocking other country domains such as .ro ( Romania) or .nl ( Netherlands)?  I have turned on spam blocking and that was no help.  I have tried setting up filters using wildcards, etc  but there are so many permutations it’s next to impossible to get them all AND they don’t work either! And it does not matter whether I use the email client on the desktop OR your web email.  They are not blocked. They never go to Spam folder they just stay in the inbox.

Gold Problem Solver

Re: out of country domain blocking

Try calling for help:

 

Comcast Customer Security Assurance: 1-888-565-4329 (7 days a week from 6AM to 2PM ET), http://security.comcast.net/get-help/contact-comca​st-security.aspx.





Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.