Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,807,910

members

60

online now

1,953,756

discussions

Top

mail boxes

New Poster

mail boxes

My e-mail shows only inbox. The trash, sent mail, etc. are not available. I have tried way of finding them to no avail. Support topics does not include about the problem.

Email Expert

Re: mail boxes

In the Folders pane, to the left of the word "Mailboxes", look for a very hard-to-see small black arrowhead.  Click on that and see if your other folders appear----------------------------

 

 

Screen Shot 2016-03-14 at 10.56.17 AM.jpg




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: mail boxes

There is nothing showing on the  folder pane. It is empty.

Email Expert

Re: mail boxes

Does it look like this----------------------?

 

Screen Shot 2016-03-14 at 3.03.04 PM.jpg




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: mail boxes

No, the panel is blank. No mailboxes label or folder sign.

Email Expert

Re: mail boxes


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way. If it works OK then you will know the problem probably lies with the first browser. eg: if you are using Internet Explorer, try Chrome or Firefox.

Also, you could try switching from the Full version of Xfinity Connect to the Lite version. Go to Preferences>>>>General, and see which one you're using now. Full is the default. Select the Lite version.

If you are using IE 10 or 11, make sure Compatibility mode is enabled for comcast.net. You will find it in IE under "Tools".




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: mail boxes

To Latoque: The first advice worked. My e-mail is now showing the mailboxex. Thanks!