Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,727,515

members

44

online now

1,889,407

discussions

Back to Top

m.comcast.net email not working....

SOLVED
Posted by
Contributor

Message 1 of 45
7,471 Views

As of 04-25-13 m.comcast.net email is forwarding to the calendar page instead of the email page.  I just see a blank screen where the email normally is.  All the other tabs are working correctly.

 

People are reporting a similar issue with the Xfinity Mobile app although they're saying it's partially fixed now.  http://forums.comcast.com/t5/Xfinity-Connect-Mobile-App/Xfinity-Mobile-App-email-goes-to-calendar/td... The app isn't available for my Nokia Symbian OS phone though.  I've tried two different phone browsers with the same results.

 

If you go to http://m.comcast.net/m/ on a computer browser and hover your mouse over the email you can see it's pointing to http://calendar.comcast.net/xcon.

 

Anyone else with similiar issues?  Thanks

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
Frequent Visitor

Message 34 of 45
7,435 Views
Solution

The email is now working on my phone. It looks a little different but it is readable.  I'm using opera mini on a LG Rumor.

Thank you.

44 REPLIES
Posted by
Gold Problem Solver

Message 2 of 45
7,467 Views

I just typed m.comcast.net, just that, nothing else... as I always do and went directly to the mobile email.

 

I also clicked on your link and went right in too.

 

Clear your cache maybe?

CC

 

M.comcast.net.JPG

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Contributor

Message 3 of 45
7,460 Views

What is the email URL you're getting forwarded too please.

Posted by
Service Expert

Message 4 of 45
7,454 Views

STPL wrote:

As of 04-25-13 m.comcast.net email is forwarding to the calendar page instead of the email page.  I just see a blank screen where the email normally is.  All the other tabs are working correctly.

 

People are reporting a similar issue with the Xfinity Mobile app although they're saying it's partially fixed now.  http://forums.comcast.com/t5/Xfinity-Connect-Mobile-App/Xfinity-Mobile-App-email-goes-to-calendar/td... The app isn't available for my Nokia Symbian OS phone though.  I've tried two different phone browsers with the same results.

 

If you go to http://m.comcast.net/m/ on a computer browser and hover your mouse over the email you can see it's pointing to http://calendar.comcast.net/xcon.

 

Anyone else with similiar issues?  Thanks

 

 

 

 


I see the same link that you do, but when I click on email it takes a bit to load, but I do get the email listing.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

Posted by
Contributor

Message 5 of 45
7,441 Views

Thanks Again. I just waited 5 minutes and I'm still stuck on the http://calendar.comcast.net/xcon/ blank page.  It seems odd that some people with the Xfinity app were having the same issues starting yesterday.  Something's changed.  I've used it successfully for years.  Why does the email link point to the calendar?

Posted by
Gold Problem Solver

Message 6 of 45
7,419 Views
Posted by
Contributor

Message 7 of 45
7,411 Views

Thank you Bruce.  Not that I paid much attention to the email URL before but zimbra sounds very familiar.  When I go to http://smartzone.mail.comcast.net/zimbra/m/zmain on my phone it looks like my mobile login page but then after logging in it forwards me to the regular xfinity.comcast.net site.  My emails do show there but I don't want to load that whole page on my phone just to see my emails.  The mobile site email link worked fine two days ago.

Posted by
Frequent Visitor

Message 8 of 45
7,371 Views

I've been getting redirected to calendar for 2 days now Comcast has been no help. Wasted an hour with them.

Posted by
Gold Problem Solver

Message 9 of 45
7,366 Views

I did notify the Administrator of this htread.  But since it is the weekend, he may not see that notification until the beginning of the business week.

CC



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Contributor

Message 10 of 45
7,333 Views

I appreciate you reporting it CC and glad to see I'm not alone.  Hopefully they can come up with a fix.

Posted by
Regular Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 11 of 45
7,315 Views

I have been having this problem for a long time. Off and on I can't create an email, nor forward or reply; with only a white screen appearing.  Now it has gotten more annoying, in that I had created draft emails, that are now locked - meaning I can't edit them and then send the drafted email.  I have called Comcast twice on this problem. Both times were told they do not see it being a problem - even though (most recently) the technician entered my account and had the exact same problem. Then the technician was able to create an email from my account (to: my account).  But then I couldn't reply to my that email (from my account).   

 

This problem is more than impacting social needs for email to work properly. My child is quite ill and the drafted email is for her physician at a Boston hospital.  I stressed the importance of this issue and they finally created a 'ticket' to send the technical issue to their technical department. I was told it would be resolved in 24-48 hours. The ticket was sent over 48 hours ago.

Posted by
Frequent Visitor

Message 12 of 45
7,278 Views

These problems are occurring with smart phones. It is xfinity's mobile web site that has the problem. I see that many different types of phones have had this problem which still exists.

 

Posted by
Official Employee

Message 13 of 45
7,262 Views

The issue with m.comcast.net should now be resolved.  We discovered a redirect wasn't functioning as expected and fixed the issue on Friday.  If you're still having issues accessing email through m.comcast.net, you'll want to clear your browsing history and try again.




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Official Employee

Message 14 of 45
7,261 Views

Carol,

An updated version of the mobile email site is coming very shortly.  It should address many of the issues you're mentioning.  




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Gold Problem Solver

Message 15 of 45
7,254 Views
Jordan,
Thank you for the update, I appreciate it.

Carole


Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Regular Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 16 of 45
7,246 Views

Dear Jordon, thank you for working on the problem. Unfortunately it has not resolved the problem for my account (ticket #CR318822125).  I have cleared all browsing data 2 times since I viewed your posting; as well as logging out and closing the window; then relaunching Chrome.  I still am unable to create a new email, reply, or edit a drafted email message; when accessing via my INBOX.

 

FYI: I access comcast email from the xfinity online website access; not a mobile phone, nor front end (ie. Outlook).

 

Please let me know ASAP when you can resolve the problem. Thank you. - Carol

Posted by
Frequent Visitor

Message 17 of 45
7,217 Views

I cleared my browers history. Stil is not working. Same isssue.

Clicking on email at

m.comcast.net/m/

is always directed to

calendar.comcast.net/xcon/

which is a blank screen.

 

 

Posted by
Contributor

Message 18 of 45
7,195 Views

It not fixed for me either on both of my smart phones browsers.  The same issue as larocqueman described.

Posted by
Official Employee

Message 19 of 45
7,194 Views

What do you see if you go to http://smartzone.mail.comcast.net/zimbra/m/zmain directly?




Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Contributor

Message 20 of 45
7,189 Views

As I posted above.  "When I go to http://smartzone.mail.comcast.net/zimbra/m/zmain on my phone it looks like my mobile login page but then after logging in it forwards me to the regular xfinity.comcast.net site.  My emails do show there but I don't want to load that whole page on my phone just to see my emails."

Posted by
Frequent Visitor

Message 21 of 45
7,185 Views

Same as STPL. That is not a useful page for a phone.

Posted by
Regular Visitor
  • Congrats on Posting your first topic!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 22 of 45
7,160 Views

Jordan, to answer your question, when I clicked on " http://smartzone.mail.comcast.net/zimbra/m/zmain directly" I am brought to a very basic (non html) Zimbra Inbox (access) to email - but much prefer the layout that I have had for email, since I started with Comcast over the past 5 years.

 

 

Posted by
Contributor

Message 23 of 45
7,151 Views

Carol I think you need to start your own thread.  You're bringing up a totally different issue that has nothing to do with my original post and is confusing the issue.  My post has to do with smart phone access on the mobile m.comcast.net site only.

 

"FYI: I access comcast email from the xfinity online website access; not a mobile phone, nor front end (ie. Outlook)."

 

Good luck with your issue but it's not the same problem we're having.

 

 

Posted by
Official Employee

Message 24 of 45
7,147 Views

Hi All,

 

I'm trying to replicate the issue (I have an iPhone 5 on IOS 6.1) but am unable to get a blank page.  Can the users seeing the issue please let me know what phone and version of OS they are running?  It will help us replicate the issue quicker.

 

Thanks,

Ken Tran
Comcast Silicon Valley



Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Contributor

Message 25 of 45
7,143 Views

Ken try the Opera Mini browser which I've been using for years successfully until last week.

http://www.opera.com/mobile/iphone

It's in the app store too. TY

 

I'm on a Nokia Astound Symbian OS phone running Anna.

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 26 of 45
7,111 Views

STPL wrote:

Ken try the Opera Mini browser which I've been using for years successfully until last week.

http://www.opera.com/mobile/iphone

It's in the app store too. TY

 

I'm on a Nokia Astound Symbian OS phone running Anna.


Thanks STPL, 

 

I'm downloading the Opera browser and will try it out.  

 

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 27 of 45
7,108 Views
I have iPhone 5 with iOS 6.1. I had a problem last week. I was just redirected to this thread and tried going directly to the zimbra URL. It asked for my login info and then instead of bringing me to email it brought me to a page with several "buttons" on it (email was one of then). This time when I clicked the email button it brought up a new window with mobile email in it. So it ultimately worked this time but redirected me and caused an unnecessary new browser window to open up. So it's better, but still not great.
Posted by
Contributor

Message 28 of 45
7,099 Views

salam001c Opera Mini is NOT working any longer with m.comcast.net since last week.  I just posted it for Ken to replicate my problem.

InquisitiveOne I'm glad someone can see their emails.  Unfortunately I'm not one of them. 

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 29 of 45
7,051 Views

STPL wrote:

salam001c Opera Mini is NOT working any longer with m.comcast.net since last week.  I just posted it for Ken to replicate my problem.

InquisitiveOne I'm glad someone can see their emails.  Unfortunately I'm not one of them. 


Hi All,

 

Thanks to STPL for the tip about using Opera browser.  I was able to replicate the issue on my iPhone.  I'll be logging a bug for this with the developers.  In the meantime, if possible, you can try using a different browser on your mobile device.  Also, if you have an iPhone or Android device, you can download the XC Mobile App.  In the meantime, I'll update this thread as soon as we can get a fix.

 

Thanks,

Posted by
Frequent Visitor
Frequent Visitor
  • You have posted 10 replies to the community. Thank you for keeping the conversations going!
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 30 of 45
7,017 Views

FWIW, email on the CC mobile site is no longer working on my Sony PSP either.  I've been able to check my mail with it for several years but now it just displays a blank page, like you're experiencing. Same problem, I'm sure.  Looking forward to a fix or for it to be un-messedup.

Posted by
Official Employee

Message 31 of 45
7,003 Views

A fix is in place and is in QA hands for testing.  Once QA completes their testing and no other issues are found, the release will go out.  Maybe even by tomorrow if all goes well.

 

Ken Tran
Comcast Silicon Valley



Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Frequent Visitor

Message 32 of 45
6,919 Views

Thanks Ken.

Could you post when the fix is released?

Thanks,

JL

Posted by
Official Employee

Message 33 of 45
6,874 Views

HI All,

 

The fix is in place and I verified on my Opera mini browser that there is no longer a blank screen.  It goes to the email page now.  Can you please verify on your end and let me know.  You might need to clear your cache or close all browsers on the phone and then load up the page again.

 

Thanks,

Ken Tran
Comcast Silicon Valley



Community Icon
I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am an Offical Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am a Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark it as a solution!solution Icon
Posted by
Frequent Visitor

Message 34 of 45
7,436 Views
Solution

The email is now working on my phone. It looks a little different but it is readable.  I'm using opera mini on a LG Rumor.

Thank you.

Posted by
Contributor

Message 35 of 45
6,856 Views

Weeeeeeeeeeeeee it's working.  It's working fine on Opera Mini and my stock browser.  Thank you to CCCarole, ComcastJordan, ComcastKen and salam001c for your help!

 

 

Posted by
Gold Problem Solver

Message 36 of 45
6,740 Views
Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 37 of 45
6,604 Views

I am using Android and I'm experiencing the same problem it tries to go to calendar.  I called comcast, they put me over to Phillipines and wanted $49 to fix, they were clueless.  I called verizon and they pointed me to this forum and said eventually comcast will put in a fix.

 

Any help on solving this is appreciated!!!!

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 38 of 45
6,526 Views

I have a smart phone Android and as of this morning the problem still exists.  When you click on email icon it gets stuck trying to go over to calendar.  Please try to resolve!!!!!

Posted by
Regular Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 39 of 45
6,433 Views

Ken,

 

Is anyone working on the fix for the android?????????  Again I click on email and it trys to go over to calendar.

 

 

Posted by
Gold Problem Solver

Message 40 of 45
5,706 Views
Posted by
Frequent Visitor

Message 41 of 45
5,540 Views

This evening 7/16 something changed with m.comcast.net - it has worked fine for months on my Android but this evening it changed. It gets me to the page where I can choose Email, DVR Manager, Queue, etc., but then it takes me to a new look for email - and I can't scroll down to any of the messages. I have the Xfinity app but have liked using the m.comcast.net site better. I went to online chat and after two agents, they are clueless. I typed in that site on my laptop and it looks the same as on my phone now, but I can scroll thru messages. Does anyone else know what I am referring to? I have been Binging and checking Comcast's site - not finding any info.

Posted by
Frequent Visitor
  • You have posted 5 replies to the community. Thank you for keeping the conversations going!
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 42 of 45
5,533 Views
The whole mobile site was screwy for me. Does it require java or JavaScript? I want to change my spam setting but it sent me to a blank screen when I tried to update preferences.
Posted by
Frequent Visitor

Message 43 of 45
5,511 Views

It is something on their end and it doesn't like the Android browser. I have the Android app but don't like it as well as I do getting webmail via the browser, and the Android email application that came with the phone doesn't work in real time as far as deleting messages, etc., so it's not ideal. I wonder if there's a workaround because it still won't let me scroll down thru messages - it shows me 3 messages and that's it. I would just like to hear them admit that they did something, cos I know it isn't me - I didn't do anything different last night than I had been doing for months!!!

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 44 of 45
5,367 Views

Yes, I also started having this problem this July 2013. I use an android. Any fixes yet? Keeps redirecting me to calendar.comcast.net, can only see top 3 emails, won't allow me to scroll, replying to an email brings up a page where I can see the html code. What a mess. Can't rely on my comcast email on my phone anymore. Does anyone have a solution? Called comcast on for 45 minutes to no avail.

Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 45 of 45
3,877 Views
I'm new to Comcast email. Same thing happens. I get the "clear browser" message then blank white screen.