Welcome to Xfinity Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,844,291

members

1,307

online

36,584

topics

Top

email

Regular Visitor

email

when i log in to email it said espanol wrong should say english

Bronze Problem Solver

Re: email

If you click on the sprockety looking thing up in the upper right corner, it should take you to settings.  Then click Basic Settings.  Language is the first drop down box;  you can reset it to English there.  You may have to reload the page.

 

Capture.JPG

Email Expert

Re: email

On the Inbox page click on the gear icon in the upper right corner of the page, then on Settings.  On the next page click on "Basic settings", and check to see that English is set as the default language.




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark an Answer!solution Icon

Forums Tips and Tricks:
Tagging Posts... See More
Discussion stats
  • 2 replies
  • 114 views
  • 0 kudos
  • 3 in conversation