Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,808,891

members

51

online now

1,954,659

discussions

Top

email

New Poster

email

I sign in and tap the email symbol that shows one new email is there. However, the email utility does not come up. It reverts back to Comcast Infinity homepage. What is missing here? Any suggestions for how to get to the email? Plugging in a web site on the Infinity brings up the site properly,

Email Expert

Re: email


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way. If it works OK then you will know the problem probably lies with the first browser. eg: if you are using Internet Explorer, try Chrome or Firefox.

Also, you could try switching from the Full version of Xfinity Connect to the Lite version. Go to Preferences>>>>General, and see which one you're using now. Full is the default. Select the Lite version.

If you are using IE 10 or 11, make sure Compatibility mode is enabled for comcast.net. You will find it in IE under "Tools".




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: email

Thanks very much. I am back to functioning now.

Email Expert

Re: email

Others reading this will want to know--------which of the suggestions was it that fixed the issue for you?




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: email

My apologies. It was a long story. I downloaded Windows 10 and new things were installed--so I really don't know. Maybe Explorer 11 had the answer. Sorry not to be able to help others with this problem.