Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,805,193

members

78

online now

1,951,702

discussions

Top

email does not open for four days

New Poster

email does not open for four days

I have not been able to open and read emails for four days now. Sometimes I can see the list of waiting emails and sometimes not. Sometimes I can delete some and sometimes not. What is going on?

Email Expert

Re: email does not open for four days

We need better information.  Are you using only the Comcast webmail, or a client like Outlook, Thunderbird, or Mac Mail?  What happens when you try to open an email?

 




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon

New Poster

Re: email does not open for four days

I am using Comcast webmail, but I also have Internet Explorer. When I try to open an email, I usually get just a blank page. Also I can only see my inbox when I first turn my computer on and sign in. After that, when I click on an email, the page goes blank and I cannot get back to the inbox without turning the computer off and starting again. I am using a PC, do not have any other device, no cell phone or other wireless.

Email Expert

Re: email does not open for four days


Try clearing out your browser's cache/browsing history. When you have done that, close out the browser and re-start it in a fresh session.

If that doesn't do it, then try using a different browser and see if you can duplicate the problem that way. If it works OK then you will know the problem probably lies with the first browser. eg: if you are using Internet Explorer, try Chrome or Firefox

If you are using IE 10 or 11, make sure Compatibility mode is enabled for comcast.net. You will find it in IE under "Tools".




Community Icon
I am not a Comcast employee, I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help. For information on the program click here.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee. I am a paying customer just like you!
I am an XFINITY Forum Expert and I am here to help.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark it as an accepted solution!solution Icon
Community Icon
I am not a Comcast employee.

Was your question answered?
Mark it as a solution!solution Icon