Welcome to Comcast Help & Support Forums
Find solutions, share knowledge, and get answers from customers and experts

New to the Community? Start here.

5,726,306

members

9

online now

1,888,391

discussions

Back to Top

cannot send email

SOLVED
Posted by
Frequent Visitor
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.
  • Congrats on Posting your first topic!

Message 1 of 4
775 Views

My outgoing email stopped working on 2/9.  I've cleared my outbox and tried test messages but still cannot send.  I can receive fine.  I've made no changes to my Outlook client or Comcast account.  Are comcast email servers down?

1 ACCEPTED SOLUTION

Accepted Solutions
Posted by
Gold Problem Solver

Message 2 of 4
799 Views
Solution

ColoHusker wrote:

My outgoing email stopped working on 2/9.  I've cleared my outbox and tried test messages but still cannot send.  I can receive fine.  I've made no changes to my Outlook client or Comcast account.  Are comcast email servers down?


The problem is probably because you have not changed your SMTP Port from Port 25 to Port 465 with SSL ON.  You cannot use Port 25 any longer, it is now blocked by Comcast.

 

Go into Outlook and change SMTP to Port 465 with SSL on

Check the box which says, "This server requires authentication"

Do NOT check the box for SPA (secure password authentication)

 

See this clickable link: http://forums.comcast.com/t5/E-Mail-and-Xfinity-Connect-Help/Port-Change-Notification/m-p/1470331#U1...

 

CC

 

 

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




3 REPLIES
Posted by
Gold Problem Solver

Message 2 of 4
800 Views
Solution

ColoHusker wrote:

My outgoing email stopped working on 2/9.  I've cleared my outbox and tried test messages but still cannot send.  I can receive fine.  I've made no changes to my Outlook client or Comcast account.  Are comcast email servers down?


The problem is probably because you have not changed your SMTP Port from Port 25 to Port 465 with SSL ON.  You cannot use Port 25 any longer, it is now blocked by Comcast.

 

Go into Outlook and change SMTP to Port 465 with SSL on

Check the box which says, "This server requires authentication"

Do NOT check the box for SPA (secure password authentication)

 

See this clickable link: http://forums.comcast.com/t5/E-Mail-and-Xfinity-Connect-Help/Port-Change-Notification/m-p/1470331#U1...

 

CC

 

 

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Gold Problem Solver

Message 3 of 4
767 Views
Posted by
New Poster
  • Thank you contributor for your first reply to the community!
 Posting replies is the best way to get involved.

Message 4 of 4
694 Views

What right does Comcast have to prevent me from sending email???? I pay $159 a month for a "bundled service" and Just like that, they cut off my being able to send email. May be time for another server!